Dismounted partitions after boot Odroid HC2

    • OMV 4.x
    • Resolved
    • Dismounted partitions after boot Odroid HC2


      I'm having issues with my OMV 4.1.14-1. and Odroid HC2 with ext4 partitions on a WD Red.
      I'm very new to it and I completely lack most knowledge about Linux.
      I am using an Odroid HC2 with a WD Red 4TB, partitioned via SSH and the internal Debian (Armian?) tool into 2 ext4 partitions.
      However, booting sometimes fails, or takes soo long that I perceive it to be failed (so I disconnect the power) and when it finally does boot the partitions are unmounted and 2 partitions are missing and named rather odd ( /dev/disk/by-id/ata-WDC_WD40EFRX-....-part1 and -part2)
      The naming suggests it is my WD Red, which is still connected and 2 "normal" partitions on the WD Red are also available, but not mounted initially.
      Is the issue anything to worry about? Does the HC2 fail to boot or is s.m.a.r.t. or anything else causing it to just take far too long?

      I'd be happy for some insight.
      • OMV ext4 WD RED.jpg

        224.03 kB, 1,920×1,336, viewed 415 times
      • OMV ext4 WD RED2.jpg

        216.47 kB, 1,920×1,336, viewed 283 times

      The post was edited 1 time, last by EvilOnion ().

    • Hey thanks,
      I went through the thread and the odroid wiki, but I don't understand how to upload the firmware updater for the sata controller to the HC2.

      Download JMS578 F/W updater and upload it to your HC1, HC2 and USB3.0 to SATA Bridge Board Plus

      root@odroid:~# ls
      root@odroid:~# tar xzf JMS578FwUpdater.tgz
      root@odroid:~# ls -l
      total 308
      drwxr-xr-x 2 root root 4096 Nov 1 05:34 JMS578FwUpdater
      -rw-r--r-- 1 root root 309402 Nov 1 05:35 JMS578FwUpdater.tgz
      root@odroid:~# cd JMS578FwUpdater
      root@odroid:~/JMS578FwUpdater# ls -l
      total 4648
      -rwxr-xr-x 1 root root 50688 Nov 1 14:34 JMS578-v0.1.0.5.bin
      -rwxr-xr-x 1 root root 4130828 Apr 19 12:06 JMS578FwUpdate
      -rwxr-xr-x 1 root root 519032 Nov 1 14:34 JMS578FwUpdate.v1.00
      -rw-r--r-- 1 root root 50688 Dec 5 10:36 JMS578_Hardkernel_v173.01.00.01.bin

      root@odroid:~# ./JMS578FwUpdate -d /dev/sda -f ./JMS578_Hardkernel_v173.01.00.01.bin -b ./backup.bin -t 5
      Update Firmware file name: ./JMS578_Hardkernel_v173.01.00.01.bin
      Backup Firmware file name: ./backup.bin
      Auto spin-down timer: 5 min.
      Backup the ROM code successfully.
      Programming & Compare Success!
      Since I don't have experience with these commands (I just read about them), I assume that you have to put the tgz file on the microsd card, either under /dev/mmcblk1p1 or mmcblk1p2 then "unzip" it.
      Then execute the JMS578FwUpdate file in the ./ folder. Since I don't really want any spindown I'd set it to -t 0. (heard spindown isn't that healthy for a drive, though honestly, I don't care too much about it)

      The main issue is how to get the file on the microsd card. Seems like a minor issue to many probably, but since I don't have any experience with Linux I find it rather odd, since I can't access the microsd card under Windows and have no idea how to get the file there.

      The post was edited 1 time, last by EvilOnion ().

    • Please note: It is possible that the SATA is already updated, then there is no point in updating it again unless you want to change the spin down time from the default. Then just make sure to not touch the physical disk properties at all. The default spin down is a couple of minutes, I believe.

      If you still want to flash the SATA, or just want to check if the version of the firmware really is the latest:

      Get a thumbdrive and a SD card reader. (Or use a PC/Laptop with a SD card reader.)

      Then install some version of Linux on the thumbdrive and boot from that and use this and the SD card reader in a PC to copy over the SATA upgrade tools to the SD card.

      You will need this anyway to be able to make a backup of the SD card when you got everything running.

      I either use a HP Laptop with a built-in SD card reader, with Ubuntu 18.04, or copy files over the network from another OMV NAS or another Linux computer. I also created an "updater SD card" with Armbian. I put firmware updates on that and insert it in one HC2 after another, boot and update over SSH. That was how I updated SATA and spin down on my Odroid HC2s. I kept the card for future updates or for when/if I get more HC2s..

      There has been cases where the spin down doesn't work correctly. Then the spin down may have caused the HDD to age prematurely. But this is not the case if you update SATA and set the spin down there. I have my spin down set to 30 minutes. It makes the HC2s more quiet and they run cooler. And I believe it is beneficial for the life of the HDD, or at least not at all harmful.
      OMV 4: 9 x Odroid HC2 + 1 x Odroid HC1 + 1 x Raspberry Pi 4

      The post was edited 2 times, last by Adoby ().

    • EvilOnion wrote:

      The main issue is how to get the file on the microsd card. Seems like a minor issue to many probably, but since I don't have any experience with Linux I find it rather odd, since I can't access the microsd card under Windows and have no idea how to get the file there.
      With FileZilla or WinSCP you can access your server and copy files between your server and your Windows client.

      Or just execute this command:
      wget https://wiki.odroid.com/_media/odroid-xu4/software/jms578fwupdater.tgz
      Odroid HC2 - armbian - OMV5.x | Asrock Q1900DC-ITX - Intenso SSD 120GB - OMV5.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV5 Documentation - user guide :!:
    • I tried to use an Ubuntu on a usb flash drive, but it wouldn't let me write on the partition ... odd

      So I tried to use the wget function and it worked like a charm. Thanks.

      However, now my very limited knowledge about the structure of Linux is catching up to me and I don't know how to make it display the version of the firmware and before I flash it would certainly be good to know what firmware is already installed.

      root@odroid:~# ./JMS578FwUpdate -d /dev/sda -v should display it, with sda being the partition label I assume.

      For me this should either be /dev/mmcblk1p1 or /dev/mmcblk1p2 I guess.

      However it just Returns: error: ioctl fail, errno 22

      On the bright side this exercise really helps me to get a little bit more familiar with Linux, which I was planning for a long time, but never did :)

      Edit: Apparently the sata controller is only active if a sata drive is connected. ./JMS578FwUpdate -d /dev/sda1 -v displays version v173.1.0.1. So it is already the current firmware.

      Anyway this was a great learning experience and getting less afraid of actually using Linux and associated functions and tools.

      Many thanks to everyone who replied. :)
      • OMV cat proc.jpg

        266.8 kB, 1,920×1,336, viewed 249 times
      • OMV JMS578.jpg

        244.92 kB, 1,920×1,336, viewed 209 times

      The post was edited 2 times, last by EvilOnion ().