How do you turn OFF auto HDD spin-down?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • How do you turn OFF auto HDD spin-down?

      Howdy. :)

      I have an HC2 setup with a 4TB WD Red drive, and everything is working, but OMV is still spinning-down the drive after about 2 minutes, despite my telling OMV NOT to do this.

      Advanced Power Management: 254 - Maximum performance, maximum power
      Automatic Acoustic Management: Maximum performance, maximum acoustic output
      Spindown time: 330 minutes.

      Yet, OMV is still spinning down the drive after about two minutes of no activity. I really need the drive to stay alive and spinning 24/7, as all the start/stop cycles are not good for a NAS drive running 24/7.....

      Can anyone offer any pointers as to what else I need to change?
    • You update/reflash the SATA firmware and specify the new spindown time then. If you set spindown to 0 it is disabled.

      Also note that some harddrives have problems with hdparm. If you set ANY of the physical disk properties in OMV, then hdparm tries to set them and disks may fail to mount. Or even unmount spontaneously. Some drives are fine. Your drive seems to be in between. Works mostly but ignore change spindown settings.

      I recommend that you disable all of the physical disk properties. Just to be safe and to avoid that hdparm tries to change settings on your HDD, and possibly fail.

      I have set my HDDs to spindown after 30 minutes. I don't think spindown/spinup cause any harm to my HDDs. But it may be that bad hdparm settings and/or old SATA firmware in combination with some HDDs spindown noisily and age prematurely according to SMART. After I flashed SATA firmware and disabled any settings in physical disk properties this problem went away. Now my HDDs spin down fine and reduce power needed and runs cooler.
      OMV 4, 5 x ODROID HC2, 2 x 12TB, 2 x 8 TB, 1 x 500 GB SSD, GbE, WiFi mesh

      The post was edited 3 times, last by Adoby ().