upgrade 3->4, Failed to start The PHP 7.0

    • OMV 4.x
    • Resolved
    • Upgrade 3.x -> 4.x
    • upgrade 3->4, Failed to start The PHP 7.0

      Afdter my server failed a few days ago (hardware fault) I did a quick change of HW. While doing so, I realized, ooohps, Iam a bit outdated :/ as I was still running OMV2.xsomewhat...
      After succesfull change of HW an reinitalizing I started with upgrades.
      I didn't bother too much after the upgrade to 3.xx, continued to 4.xx
      unfortunately I cannot access the WebGUI. Following problem comes up all the time:

      Source Code

      1. root@mediavault:~# dpkg --configure -a
      2. php7.0-fpm (7.0.33-0+deb9u1) wird eingerichtet ...
      3. NOTICE: Not enabling PHP 7.0 FPM by default.
      4. NOTICE: To enable PHP 7.0 FPM in Apache2 do:
      5. NOTICE: a2enmod proxy_fcgi setenvif
      6. NOTICE: a2enconf php7.0-fpm
      7. NOTICE: You are seeing this message because you have apache2 package installed.
      8. Job for php7.0-fpm.service failed because the control process exited with error code.
      9. See "systemctl status php7.0-fpm.service" and "journalctl -xe" for details.
      10. invoke-rc.d: initscript php7.0-fpm, action "start" failed.
      11. ● php7.0-fpm.service - The PHP 7.0 FastCGI Process Manager
      12. Loaded: loaded (/lib/systemd/system/php7.0-fpm.service; enabled; vendor preset: enabled)
      13. Active: failed (Result: exit-code) since Sat 2018-12-15 15:57:28 CET; 13ms ago
      14. Docs: man:php-fpm7.0(8)
      15. Process: 5715 ExecStart=/usr/sbin/php-fpm7.0 --nodaemonize --fpm-config /etc/php/7.0/fpm/php-fpm.conf (code=exited, status=78)
      16. Main PID: 5715 (code=exited, status=78)
      17. Dez 15 15:57:28 mediavault systemd[1]: Starting The PHP 7.0 FastCGI Process Manager...
      18. Dez 15 15:57:28 mediavault php-fpm7.0[5715]: [15-Dec-2018 15:57:28] ERROR: [pool openmediavault-webgui] cannot get uid for user 'openmediavault-webgui'
      19. Dez 15 15:57:28 mediavault php-fpm7.0[5715]: [15-Dec-2018 15:57:28] ERROR: FPM initialization failed
      20. Dez 15 15:57:28 mediavault systemd[1]: php7.0-fpm.service: Main process exited, code=exited, status=78/n/a
      21. Dez 15 15:57:28 mediavault systemd[1]: Failed to start The PHP 7.0 FastCGI Process Manager.
      22. Dez 15 15:57:28 mediavault systemd[1]: php7.0-fpm.service: Unit entered failed state.
      23. Dez 15 15:57:28 mediavault systemd[1]: php7.0-fpm.service: Failed with result 'exit-code'.
      24. Hint: Some lines were ellipsized, use -l to show in full.
      25. dpkg: Fehler beim Bearbeiten des Paketes php7.0-fpm (--configure):
      26. Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
      27. openmediavault (4.1.15-1) wird eingerichtet ...
      28. Updating configuration database ...
      29. chown: invalid group: ‘:openmediavault-config’
      30. ERROR: Failed to create the default configuration: Command '['/usr/share/openmediavault/confdb/create.d/conf.sh']' returned non-zero exit status 1
      31. dpkg: Fehler beim Bearbeiten des Paketes openmediavault (--configure):
      32. Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
      33. Fehler traten auf beim Bearbeiten von:
      34. php7.0-fpm
      35. openmediavault
      Display All


      I tried already to reinstall it, but with the same result

      Source Code

      1. root@mediavault:~# systemctl restart apache2
      2. root@mediavault:~# systemctl status php7.0-fpm.service
      3. ● php7.0-fpm.service - The PHP 7.0 FastCGI Process Manager
      4. Loaded: loaded (/lib/systemd/system/php7.0-fpm.service; enabled; vendor preset: enabled)
      5. Active: failed (Result: exit-code) since Sat 2018-12-15 16:00:42 CET; 1min 13s ago
      6. Docs: man:php-fpm7.0(8)
      7. Process: 6950 ExecStart=/usr/sbin/php-fpm7.0 --nodaemonize --fpm-config /etc/php/7.0/fpm/php-fpm.conf (code=exited, status=78)
      8. Main PID: 6950 (code=exited, status=78)
      9. Dez 15 16:00:42 mediavault systemd[1]: Starting The PHP 7.0 FastCGI Process Manager...
      10. Dez 15 16:00:42 mediavault php-fpm7.0[6950]: [15-Dec-2018 16:00:42] ERROR: [pool openmediavault-webgui] cannot get uid for user 'openmediavault-webgui'
      11. Dez 15 16:00:42 mediavault php-fpm7.0[6950]: [15-Dec-2018 16:00:42] ERROR: FPM initialization failed
      12. Dez 15 16:00:42 mediavault systemd[1]: php7.0-fpm.service: Main process exited, code=exited, status=78/n/a
      13. Dez 15 16:00:42 mediavault systemd[1]: Failed to start The PHP 7.0 FastCGI Process Manager.
      14. Dez 15 16:00:42 mediavault systemd[1]: php7.0-fpm.service: Unit entered failed state.
      15. Dez 15 16:00:42 mediavault systemd[1]: php7.0-fpm.service: Failed with result 'exit-code'.
      16. root@mediavault:~# ^C
      Display All
      The server tisself works fine, I can access all my files on it, ssh abviously works also, there is just no chance to access the WebGUI, 192.168.x.xx:81 just says: 502 bad gateway, nginx
      Ie removed all extras aswell before upgrading:

      Source Code

      1. root@mediavault:~# dpkg -l | grep openmediavault
      2. iF openmediavault 4.1.15-1 all openmediavault - The open network attached storage solution
      3. ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      4. root@mediavault:~#
      Any help would be very much appreciated....... :rolleyes: :rolleyes: :rolleyes: :rolleyes: :rolleyes:
    • Users Online 1

      1 Guest