NFS won't mount after OMV reboot

    • OMV 4.x
    • NFS won't mount after OMV reboot

      hi all

      I have setup OMV to expose NFS mounts for an OSMC player. Issue I'm having is whenever I reboot OMV, I lose those mounts, if I try to browse a mount manually through terminal I get 'permission denied'. Have tried umount -f /mnt/SHARE and then mount -a, no luck.

      Once I've lost the shares - if I go into OMV GUI and then delete the share and recreate, I get a stale handle on client side which I can then force unmount and remount which works fine again.

      I've seen a few similar posts but no conclusive solution.

      Any ideas?

      Thanks! :)
    • Reboot the client when the server is up again. Strange that mount -a doesn't work...

      I use autofs. I don't involve OMV at all in mounting remote NFS shares, only in providing the shares.

      I have four OMV servers. They all provide NFS shares and they all mount each other's share using autofs. Works fine. Very stable. If a server is disconnected or rebooted, the mounts are dropped and restored on demand automagically.

      You might prefer to use systemd.automount instead of autofs. It is the modern way. But I don't know if the OSMC player supports it. Or even if it supports autofs.
      OMV 4, 7 x ODROID HC2, 1 x ODROID HC1, 5 x 12TB, 1 x 8TB, 1 x 2TB SSHD, 1 x 500GB SSD, GbE, WiFi mesh

      The post was edited 1 time, last by Adoby ().

    • Adoby wrote:

      Reboot the client when the server is up again. Strange that mount -a doesn't work...

      I use autofs. I don't involve OMV at all in mounting remote NFS shares, only in providing the shares.

      I have four OMV servers. They all provide NFS shares and they all mount each other's share using autofs. Works fine. Very stable. If a server is disconnected or rebooted, the mounts are dropped and restored on demand automagically.

      You might prefer to use systemd.automount instead of autofs. It is the modern way. But I don't know if the OSMC player supports it. Or even if it supports autofs.
      Thanks for the tips Adoby.

      Yea I tried rebooting client several times and no joy. Only way I can remount is by deleting the NFS share in OMV gui and then adding it in again.

      I'll check out autofs. OSMC is based on Debian so hopefully should be ok.

      Should have mentioned I'm using systemd.automount with fstab currently on client.

      The post was edited 1 time, last by elstevo ().