Share Issue (on Windows & Raspberry Pi) - Cannot delete directory (and subdirectories)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Share Issue (on Windows & Raspberry Pi) - Cannot delete directory (and subdirectories)

      New

      Hi all!

      Long time user - first time poster. Ran into something that has me a little baffled. I use a Pi for doing some Python development - but I do the coding on my Windows machine (better editor); I had a share setup for this called 'coding'.

      Previously it worked fine, but I can't remember exactly how I had set it up because it had been a while. Recently I had to wipe/reinstall my raspberry pi (Raspbian) and so my settings for that mounted location were lost.

      I'm 99.9% sure on the raspberry pi, I mounted it by editing /etc/fstab and put in the following:

      Source Code

      1. //my.omv.ip.x/coding /home/pi/coding cifs x-systemd.automount,credentials=/home/pi/.smbcredentials 0 0
      my username and password were set in .smbcredentials

      I did the same thing on the reinstall of raspbian and am able to mount the share with no issues! Great! I have a user in OMV specifically for the shares on the Pi and that user is a member of a Group that has Read/Write on that share.

      However, I have some directories in that share that I'd like to get rid of (a directory called 'venv' for example for Python); when I do rm -rf venv I get an error `Permission Denied` on some files and `Directory is not empty` on the directories.

      It's the same if I run sudo rm -rf venv - I get the same errors (Permission Denied and Directory not empty).

      I could previously do this without issue, so I'm not sure why now I'm having trouble.

      If I hop on my Windows box and right click on the directory and select to delete the directory, it says I have to provide `administrator permission`, when I click continue on that - it errors out saying that the drive is 'unavailable' (but it is available as I can create other files and delete other files there). My Windows machine connects with a different user I created specifically for the windows PC and has no problems.

      All of this has me thinking it's a rights issue somehow - I just don't know where to go from here. I've spent hours scouring the internet and hours trying various fixes but I'm at a loss.

      Any help would be appreciated - I'd like to have it how it was before, where I could run command line stuff in Pi to create/delete directories as needed, just don't know how to get there and can't figure out why certain directories seem un-deletable for me.