Bitwarden and Letsencrypt Remote Access Issue

    • Bitwarden and Letsencrypt Remote Access Issue

      Hi everyone I'm having a little trouble accessing bitwarden remotely through the use of duckdns and letsencrypt + reverse proxy, I hope someone can help me I'm still in the learning process.

      I developed bitwarden through docker as @TechnoDadLife explains in his tutorial

      Unfortunately the process let you with a local access through standard port, no https, so I decided to go the route duckdns+letsencrypt+reverse proxy (everything through docker) to access it remotely via https.

      Every container worked fine on its own:

      • I have my domain let's say iloveomv.duckdns.org
      • I created my subdomain inside letsencrypt docker, let's say bitwarden.iloveomv.duckdns.org
      • I open the right ports on my router and everything works fine I can see my page remotely with https answer back and the letsencrpy ssl certificate going through.



      Now the problem happens, I can't connect my bitwarden loal docker to the subdomain bitwarden.iloveomv.duckdns.org without getting the error 504 from nginx when I try to connect to it.



      Sure I suspect is an error on my part, tryng to config the bitwarden docker, so I went ahead and look at the info page of the docker itself -> bitwarden docker

      Here is the first problem as you can see, on the docker infopage itself, there is no variable to set https, it seems to operate just through http.


      Reading further there is a way to activate https trough ROCKET_TLS, and use this proxy config, for letsencrypt docker.


      So I tried this:

      • created a variable environment on the bitwarden docker as ROCKET_TLS, giving it physical access to the sharedfolder where fullchain.pem and privkey.pem produced by letsencrypt are stored
      • changed the due localhost parameter with the duckdns domain on the proxy config
      • added --network mynetwork flag to the bitwarden container to let it talk to letsencrypt container
      but none of it worked out. I'm still getting error 504 when I try to connect to bitwarden.iloveomv.duckdns.org


      Any idea what I'm doing wrong here?! can someone point me in the right direction?!

      Thank you very much in advance
    • Users Online 1

      1 Guest