Can't enable Wifi on Nanopi M4

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can't enable Wifi on Nanopi M4


      While I know wifi is not the best idea for NAS, I still want it to be enabled.
      After I set the config for wlan0 via GUI and press Apply I get an error:

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; systemctl start 'networking' 2>&1' with exit code '1': Job for networking.service failed because the control process exited with error code. See "systemctl status networking.service" and "journalctl -xe" for details.

      Source Code

      1. robbin@nanopim4:/$ ip a
      2. 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
      3. link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      4. inet scope host lo
      5. valid_lft forever preferred_lft forever
      6. inet6 ::1/128 scope host
      7. valid_lft forever preferred_lft forever
      8. 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
      9. link/ether 0e:60:64:e0:0e:d1 brd ff:ff:ff:ff:ff:ff
      10. inet brd scope global dynamic eth0
      11. valid_lft 77759sec preferred_lft 77759sec
      12. inet6 fe80::8f75:8ebe:25a3:a54a/64 scope link
      13. valid_lft forever preferred_lft forever
      14. 3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
      15. link/ether cc:4b:73:25:97:ac brd ff:ff:ff:ff:ff:ff
      16. 4: docker0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
      17. link/ether 02:42:a6:31:a2:13 brd ff:ff:ff:ff:ff:ff
      18. inet brd scope global docker0
      19. valid_lft forever preferred_lft forever
      20. 6: veth1e988ed@if5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master docker0 state UP group default
      21. link/ether 7e:db:a6:6a:5f:98 brd ff:ff:ff:ff:ff:ff link-netnsid 0
      Display All

      This robbin@nanopim4:/$ sudo ip a add dev wlan0 killed network, had to reboot the device.

      Will appreciate advice what to try to fix.
    • Robbin wrote:

      After I set the config for wlan0 via GUI
      I wouldn't do this since the base image relies on Armbian where Network Manager is the preferred way to setup wireless. After removing all wlan0 references in the UI (and checking /etc/network/interfaces that there's nothing left) I would simply call the following commands as root via SSH:

      Source Code

      1. nmcli radio
      2. nmcli device
      3. nmcli device wifi rescan
      4. nmcli device wifi list
      5. nmtui
      If everything is set up accordingly only calling nmtui and then choosing the wireless network you want to join is sufficient. The other commands are there to serve for debugging purposes so please post the output here.

      Disclaimer: I've no idea whether Wi-Fi currently works on M4 (could be a driver/firmware issue) but at least it worked in the beginning.
    • I have to bring this up again and may need some help here.

      When I checked the gui there is really one eth0 interface listed within OMV. so I tried to delete it but after confirming the changes in the gui the system hangs completely. Only hard reset will bring the system back to life but the eth0 appears everytime again.

      I´m not able to delete it within the gui properly. Any hints on how to solve this?

      by now wifi is only connecting when the lan port is connected. As soon this happens both interfaces are accessible with different IP´s. As soon lan is disconneted wifi is also not reachable.
    • tkaiser wrote:

      Most probably wlan0 is still referenced in /etc/network/interfaces. Each interface that is listed there won't be available to NetworkManager.
      Have checked this? tkaiser was referring to /etc/network/interfaces, not the GUI of OMV.
      Odroid HC2 - armbian - OMV5.x | Asrock Q1900DC-ITX - Intenso SSD 120GB - OMV5.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV5 Documentation - user guide :!: