RAID 1 set up but would not work

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • RAID 1 set up but would not work

      I made a new installation of OMV using mirrored drives but could not get past "Add shared folder". I had created a mirrored drive md0 which seemed OK, but when it came to "Select a device", no device would show up.

      Found a few threads online about a similar problem, which seemed to be related to the disks not being properly erased so tried quick erase, full erase, then DBAN but always the same result. Each erase and rebuild of mirrored drive took all day or overnight, so I was getting pretty frustrated with this! Then I found someone had fixed a similar problem by RENAMING the device (/dev/md0). I had called my system VostroNAS since the hardware was an old Dell Vostro and this was the problem. Under RAID Management the name of the device showed up as VostroNAS:0 and this just would not work.

      I didn't see a way to rename it through the GUI, so I rebuilt the array (again!) using mdadm and giving it the name Tank. Now the name under RAID Management shows up as VostroNAS:Tank. And everything works!!

      This seems to be a bug of the GUI, but I guess the lesson to be learned is DON'T change the name of your system, at least until it's up and running. :)