Omv Extras plugins not installing

    • OMV 4.x
    • Resolved
    • Omv Extras plugins not installing

      I tried to install some Omv extras plugins, but none of them is installing correctly.

      -clean install
      -followed the guide on how to install omv-extras and plugins
      -updated everything

      network connection and everything else is working nicely.

      Any help is appreciated





      Source Code

      1. >>> *************** Error ***************
      2. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-shellinabox 2>&1' with exit code '100': Reading package lists...
      3. Building dependency tree...
      4. Reading state information...
      5. Some packages could not be installed. This may mean that you have
      6. requested an impossible situation or if you are using the unstable
      7. distribution that some required packages have not yet been created
      8. or been moved out of Incoming.
      9. The following information may help to resolve the situation:
      10. The following packages have unmet dependencies:
      11. openmediavault-shellinabox : Depends: shellinabox (>= 2.18) but it is not installable
      12. E: Unable to correct problems, you have held broken packages.
      Display All
    • Did you install OMV with a network connection while it was installing? What is the output of: cat /etc/apt/sources.list
      omv 4.1.19 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Thanks for your reply

      Yes, I did install omv with a network connection. At least I hope so ;D

      cat /etc/apt/sources.list yields:

      Source Code

      1. root@openmediavault:~# cat /etc/apt/sources.list
      2. #
      3. # deb cdrom:[Debian GNU/Linux 9 _Stretch_ - Official Snapshot amd64 LIVE/INSTALL Binary 20180330-19:01]/ stretch contrib main non-free
      4. #deb cdrom:[Debian GNU/Linux 9 _Stretch_ - Official Snapshot amd64 LIVE/INSTALL Binary 20180330-19:01]/ stretch contrib main non-free
      5. deb http://security.debian.org/debian-security stretch/updates main contrib non- free
      6. deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free
    • TBenra wrote:

      Yes, I did install omv with a network connection. At least I hope so ;D
      Nope. You didn't get any sources other security (which is the same for all locations. Edit /etc/apt/sources.list and put the following lines:

      deb http://httpredir.debian.org/debian/ stretch main contrib non-freedeb http://security.debian.org/debian-security stretch/updates main contrib non-freedeb http://httpredir.debian.org/debian/ stretch-updates main contrib non-freeI filed this issue earlier to try and prevent this.
      omv 4.1.19 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • sunhort wrote:

      omv-extras.org not working now (may be from my country) ping is going but I can't get any software installed
      Server isn't down and hasn't been down that I know of. What error are you getting?
      omv 4.1.19 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!