VPN Internet Access

    • OMV 4.x
    • VPN Internet Access

      Hello guys,

      i am using OpenVPN on my omv server.
      I can connect from internet to omv with my android without problems.
      I can reach then omv gui too in vpn connection.
      But its not possible to surf in internet via vpn.
      When i am in vpn connection with my android device, it only knows the ip adresses of omv and docker container, nothing els. Not even the router ip ...

      I think my omv server creates a subnet which let me reach omv and docker container but not my "real" home network.
      I need this function for permanent vpn connection via android e.g. when i take a picture, this one will get uploaded to nextcloud instant.

      Do you understand? :D

      My omv gives me an ip adress like ... with subnet.
      This is the default setting of openVPN plugin.

      I know that the two devices in vpn connection needs different subnets.
      But how can i fix my problem?
      Does i need a second gateway interface for connection from omv to router?

      I hope someone can help me.
      Thank you!

      The post was edited 1 time, last by Cortex_A7 ().

    • Post your VPN config, blur out the internet IP or DNS.

      I have no issue with the following config:

      General settings:
      - Configure the plugin:
      - enable: true
      - port: 1194
      - use compression: true
      - PAM: true

      VPN network:
      - Address:
      - MASK:
      - Gateway interface: your internet interface (mine is ens5, but the interface is in the dropdown list just select the one connected to the internet)
      - Default gateway: true

      DHCP options
      everything is empty

      - Public address: your IP or if NO-IP use your domain.ddns.net
      Theme changer tool: Unofficial OMV Theme Changer tool, css themes and UI manipulation
      Theme changer plugin: OMV-Theme plugin, theme changer and UI customisation

      omv-theme repo: github.com/virgil-av/omv-theme
      openmediavault-theme repo: github.com/virgil-av/openmediavault-theme

      If you appreciate what i do just smash that like
    • Hey,

      thanks for help.

      It works now with the following Settings:

      Default Gateway = false

      I tryed it before but with another option. That was the reason why i thought it wont help me.
      But today i tryed again with setting it to false and now all works !! :)

      Thanks and this can be closed :thumbsup:
    • Hi all,

      Faced a similar problem.

      Connection is established successfully, but I don't see home network.

      Default gateway tried setting on and off - no difference.

      Tell me what to do.


      Maybe I did not quite understand the essence of my problem...

      I need to connect from the outside to the home network and see the samba shares.

      For this, I installed openvpn plugin in omv.
      On the router did port forwarding.
      The connection itself is established without problems.
      But I do not see the local network.

      The post was edited 1 time, last by VAFERus: add ().