[Solved] Constant harddrive related errors with fresh installation

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Constant harddrive related errors with fresh installation

      I'm running a fresh 4.1.3 installation. Followed this tutorial:


      I have an 250GB SSD where the OMV is installed and an additional 1TB HDD.
      This 1TB HDD was used in windows environment before, but after OMV installation I did a secure wipe of it from the OMV UI.

      This is how the filesystem looks at the moment:



      Everything works fine until this point, but I get an error when I try to create a shared folder.

      When I try to create a shared folder named "Media" like this:



      I get this error:


      Full error:

      Source Code

      1. Error #0:
      2. OMV\Exception: Failed to create the directory '/srv/dev-disk-by-id-ata-ST1000DM003-1SB10C_Z9A269YD-part1/Media': in /usr/share/openmediavault/engined/rpc/sharemgmt.inc:323
      3. Stack trace:
      4. #0 [internal function]: OMVRpcServiceShareMgmt->set(Array, Array)
      5. #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      6. #2 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('set', Array, Array)
      7. #3 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('ShareMgmt', 'set', Array, Array, 1)
      8. #4 {main}

      I have tried to wipe the drive again, but when I try I get this error instead: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; blockdev --rereadpt '/dev/sdb' 2>&1' with exit code '1': blockdev: ioctl error on BLKRRPART: Device or resource busy

      Error details below:

      Source Code

      1. OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; blockdev --rereadpt '/dev/sdb' 2>&1' with exit code '1': blockdev: ioctl error on BLKRRPART: Device or resource busy in /usr/share/openmediavault/engined/rpc/diskmgmt.inc:273
      2. Stack trace:
      3. #0 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMVRpcServiceDiskMgmt->{closure}('/tmp/bgstatus6i...', '/tmp/bgoutputyr...')
      4. #1 /usr/share/openmediavault/engined/rpc/diskmgmt.inc(277): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      5. #2 [internal function]: OMVRpcServiceDiskMgmt->wipe(Array, Array)
      6. #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      7. #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('wipe', Array, Array)
      8. #5 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('DiskMgmt', 'wipe', Array, Array, 1)
      9. #6 {main}
      I somehow feel that this is hard-drive related, but I can't tell exactly how. Any guidance is appreciated. Thank you!
    • If I ignore the previous error and just close the window and press "Apply"-button I get this error:


      Source Code

      1. Error #0:
      2. OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; systemctl restart 'sharedfolders-Media.mount' 2>&1' with exit code '1': Assertion failed on job for sharedfolders-Media.mount. in /usr/share/php/openmediavault/system/process.inc:182
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1)
      5. #1 /usr/share/php/openmediavault/system/systemctl.inc(160): OMV\System\SystemCtl->exec('restart', NULL, false)
      6. #2 /usr/share/openmediavault/engined/module/sharedfolders.inc(66): OMV\System\SystemCtl->restart()
      7. #3 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModuleSharedfolders->startService()
      8. #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      9. #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      11. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusX9...', '/tmp/bgoutputXE...')
      12. #8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      13. #9 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      14. #10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      15. #11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      16. #12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)
      17. #13 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)
      18. #14 {main}
      Display All

      Any idea what else could be the cause of all these errors?
    • The obvious assumption is that the hdd is bad.

      But that might be a side effect from bad cables and connections or bad or insufficient power. Try to change or at least disconnect and reconnect cables and power supply and/or remove accessories that may consume power. Try with a different hdd.

      If you want to try to wipe again, make sure to unmount the filesystems on the drive first.

      You can also try to check the hdd from the command line.

      Do a search for "fsck check hdd."

      Also make sure that OMV is OK. Update it. And/or reinstall.
      OMV 4, 7 x ODROID HC2, 1 x ODROID HC1, 5 x 12TB, 1 x 8TB, 1 x 2TB SSHD, 1 x 500GB SSD, GbE, WiFi mesh