Docker can't access shared folders after reboot

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Docker can't access shared folders after reboot

      Hello,

      After rebooting, containers have no access to shared folders - nothing shows up under shared folders when adding a folder in host path (just automatically/accidentally made files/folders since the docker is pointing there now), and dockers don't load config files properly. If I go to shared folders and change the path elsewhere and then point it back, all of my dockers work with the proper configs until I restart again. I had this happen on another install but also had weird permissions at that point, so I started over with everything new, thinking maybe it was ACL or the reset perms plugin having issues, but I havn't touched them here. I thought recursive permissions might be the issue too, but none of them interfere with each other. Everything else seems fine, I can access the files over the smb and ftp after a restart so it seems like it's just docker having the issues. Any ideas? Thanks.
    • gderf wrote:

      Try using the actual fully qualified path instead of a shared folder for host path.
      so if I'm trying to put it on my 4tb at /dev/sdb1 that is already mounted what would I do? all the tutorials I've seen say to make a shared folder and use that. This use to work for about 2 months until something happened.

      I did notice that when rebooting, its hanging at detecting the drives for a minute and 30 seconds, then moves on - it's almost like docker is loading before the drives do.

      edit: getting this for all drives:

      systemd[1]: Dependency failed for /srv/dev-disk-by-label-4tb.
      systemd[1]: srv-dev\x2ddisk\x2dby\x2dlabel\x2dDVRhdd.mount: Job srv-dev\x2ddisk\x2dby\x2dlabel\x2dDVRhdd.mount/start failed with result 'dependency'.

      they end up loading and mounting later with no issues other than docker though

      The post was edited 4 times, last by catpants ().

    • I was using /sharedfolders until recently too. Upon reboot the files would not show up. They were still under /srv/name etc.

      My setup includes mergerfs. I believe something must have changed with the last updates.

      Anyway like gderf says, if you point to the qualified path you should be ok.
      OMV 4.x running under ESX with SAS drives passed through