Applying configuration does not do anything

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Applying configuration does not do anything

      Hi,

      I'm trying out the OMV system for the first time. After a few tweaks to the setting the "The configuration has been changed. You must apply the changes in order for them to take effect." message pops up.
      Now I tried about everything and it just won't go away.

      I tried
      • Starting fresh
      • Editing the config.xml
      • ...
      Every time I press the Apply button the following popup appears


      But nothing happens. same goes for pressing revert and with a load of other commands in the system. I'm having the same problem with creating a filestorage and deleting system logs.
      The logs show no errors and I'm clueless what to do now.

      Hopefully someone can point me in the right direction
    • For custom changes it is better to change /etc/default/openmediavault

      After applying changes it is necessary to execute some commands depending on the service which was changed. For example all config entries for Samba starts with OMV_SAMBA_....

      Then execute omv-mkconf samba and systemctl restart samba (Insteadservice smbd restart should also work or simply reboot the machine).
      OMV 3.0.90 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304