[Solved]Ftp Connexion fails reading the shared folder.

    • OMV 4.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Ftp Connexion fails reading the shared folder.


      I just installed OMV and I need your help about a remote ftp access.

      Everything works pretty fine in my local area network. I can access my ftp, ssh, rsync and smb.

      Now over the internet, with a remote connexion on my phone I can access to ssh and can read all my folders.

      My problem occurs on ftp connexion and I can't read any of my shared folders.
      The connexion works very fine trought my SSL/TLS protocol until Filezilla must read my shared folder.

      Source Code

      1. Statut : Résolution de l'adresse de example.ddns.net
      2. Statut : Connexion à xx.xx.xxx.xxx:2020...
      3. Statut : Connexion établie, attente du message d'accueil...
      4. Statut : Initialisation de TLS...
      5. Statut : Vérification du certificat...
      6. Statut : Connexion TLS établie.
      7. Statut : Connecté
      8. Statut : Récupération du contenu du dossier "/"...
      9. Commande : CWD /
      10. Réponse : 250 Commande CWD exécutée avec succès
      11. Commande : TYPE I
      12. Réponse : 200 Type paramétré à I
      13. Commande : PASV
      14. Réponse : 227 Entering Passive Mode (92,129,222,238,165,249).
      15. Commande : MLSD
      16. Erreur : Connection interrompue après 20 secondes d'inactivité
      17. Erreur : Impossible de récupérer le contenu du dossier
      Display All

      I am connecting with a masquerade adresse over the Internet. (noip relayed address which works fine with ssh connexion and web administration OVM pannel )
      I tried some differents ports as well. (21 does not work at all and I don't know why. Not firewalled).
      All my ports are well redirected in NAT/PAT.

      I don't use ACL as specified in the forum, my user has read/write right privileges on the shared folder and the folder has been set as shared.

      So I must tell that my configuration is a little weird. My first router is connected to the Internet and I have a second router connected to this first router. My OVM server is connected to this second router. I don' know if my problem come with that. However all my cameras are visibles trough this router.
      Do you think ?

      I have read tons of similar threads and was unable to fix this.

      Have any suggestions about this matter ?

      My shared folder is located at /srv/dev-disk-by-label-Western ----Normal ?

      Thanks in advance for your shared time.