No devices under shared folders (encrypted drive)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • No devices under shared folders (encrypted drive)

      Hi there,

      I'm currently setting up OMV on an Odroid HC2.

      However I have problems sharing a folder as the devices list doesn't show my drive (or anything).
      Does anyone know what OMV is looking for when identifying devices?

      For the record, part of the problem might be the drive encryption. I did NOT use the Luks plugin, as Luks uses base64 encoding, that would effectively reduce my 4tb drive to 3tb.

      Hence I instead (not in OMV but ssh to Debian)
      - gparted the attached hard drive with a single partition,
      - installed veracrypt under debian, encrypted the partition and mounted it.

      Everything shows in OMV under file systems:
      - the sd card partitions with OMV
      - sda1 partition is there… not mounted (ok as encrypted)
      - veracrypt mount is there, too - as device 'dev/mapper/veracrypt1'… label 'Data' and mounted under /media/veracrypt1

      So what do I have to do to get the encrypted partition found as device in shared folders (if file systems clearly sees it)?

      Different mount point? Label?

      Thanks a lot for you help :)
    • Ok… managed to figure it out myself...
      Here's how to make OMV work with veracrypt (short version, new install… new empty drive):

      - enable ssh
      - ssh as root into OMV(Debian)
      - gpart the attached hard drive (eg sda) with a single partition, here sda1 (or two or three... ),
      - install veracrypt under debian (tutorials for rpi should help, I downloaded a *. deb file for armhf -using an Odroid myself - here software.opensuse.org/download…racrypt&package=veracrypt )
      - encrypt the new partition (sda1)
      - in case the new partition hasn't got a label… label it with eg e2label (if it is ext4)… eg 'Data'
      - mkdir /srv/dev-disk-by-label-Data (if label is Data)
      - mount sda1 to /srv/dev-disk-by-label-Data

      Now everything should show up under devices
      (one additional step I did was manually entering the mntent section in the OMV config.xml… but I think that's not needed).