RaspberryPi3 Problem apt-get update && apt-get dist-upgrade

    • OMV 4.x
    • Update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • RaspberryPi3 Problem apt-get update && apt-get dist-upgrade

      Hello,

      i have Problems with apt-get update and apt-get dist-upgrade. I have a Rasberry Pi 3 with OMV 4.1.19-1. My problem see attachments.

      Best Regards
      Files
      • problem.txt

        (88.7 kB, downloaded 50 times, last: )
      PC: CaseLabs Mercury S3 | Intel Core i5-4670K 4x 3.40GHz | 16GB DDR3-2133 MHz Corsair Dominator Platinum | KFA² GeForce GTX 1080 Ti Hall Of Fame, 11GB GDDR5X | 1x Crucial M500 240GB | 1x Crucial MX300 525GB | Windows 10 Pro 64-Bit
    • I don't see an apt-get update in your output. I would guess that is why dist-upgrade can't find the packages.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • CaparZo wrote:

      so now you can see apt-get update.
      You still must have outdated lists. Does omv-aptclean help?
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • No, same problem and i find new problems:

      flash memory and all performance statistics not working...
      Files
      • problem.txt

        (23.09 kB, downloaded 36 times, last: )
      PC: CaseLabs Mercury S3 | Intel Core i5-4670K 4x 3.40GHz | 16GB DDR3-2133 MHz Corsair Dominator Platinum | KFA² GeForce GTX 1080 Ti Hall Of Fame, 11GB GDDR5X | 1x Crucial M500 240GB | 1x Crucial MX300 525GB | Windows 10 Pro 64-Bit
    • Looks like you upgraded this system from 3.x (we recommend a fresh install) and there are still a bunch of jessie entries. What is the output of:

      cat /etc/apt/sources.list
      cat /etc/apt/sources.list.d/*
      dpkg -l | grep openm
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • No, OMV4 is a new install no upgrade from OMV3.x. The line with jessie code:

      Source Code

      1. deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
      2. deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi
      I have change in:

      Source Code

      1. deb http://mirrordirector.raspbian.org/raspbian/ stretch main contrib non-free rpi
      2. deb-src http://archive.raspbian.org/raspbian/ stretch main contrib non-free rpi
      After this change, i have omv-aptclean and apt-get autoclean execute. The problem is the same.
      Files
      • results.txt

        (3.79 kB, downloaded 28 times, last: )
      PC: CaseLabs Mercury S3 | Intel Core i5-4670K 4x 3.40GHz | 16GB DDR3-2133 MHz Corsair Dominator Platinum | KFA² GeForce GTX 1080 Ti Hall Of Fame, 11GB GDDR5X | 1x Crucial M500 240GB | 1x Crucial MX300 525GB | Windows 10 Pro 64-Bit
    • My first problem can I fixed. here my solution way:


      Source Code

      1. sudo cd /var/lib/dpkg/info/
      2. sudo ls -l
      3. sudo dpkg --list | grep '^rc '
      4. sudo dpkg --purge `dpkg --get-selections | grep deinstall | cut -f1`
      5. sudo ls -l (when is empty it's ok, when not delete all in this folder)
      6. sudo /var/lib/dpkg/info# rm *
      7. sudo /var/lib/dpkg/info# ls -l
      8. total 0
      9. sudo apt-get clean
      10. sudo omv-aptclean
      11. sudo dpkg --configure -a
      12. sudo apt-get dist-upgrade
      Display All
      After this last commando you become the statement:

      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Calculating upgrade... Done
      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

      You can the complete solution way see in my attachment.

      Best regards
      Files
      • repair.txt

        (181.22 kB, downloaded 47 times, last: )
      PC: CaseLabs Mercury S3 | Intel Core i5-4670K 4x 3.40GHz | 16GB DDR3-2133 MHz Corsair Dominator Platinum | KFA² GeForce GTX 1080 Ti Hall Of Fame, 11GB GDDR5X | 1x Crucial M500 240GB | 1x Crucial MX300 525GB | Windows 10 Pro 64-Bit
    • so now all performance statistics works, i think the databank has crashed. here my solution way:

      Source Code

      1. sudo service collectd stop
      2. sudo rm -r /var/lib/rrdcached/db/*
      3. sudo service collectd start
      so only the flash memory not working
      PC: CaseLabs Mercury S3 | Intel Core i5-4670K 4x 3.40GHz | 16GB DDR3-2133 MHz Corsair Dominator Platinum | KFA² GeForce GTX 1080 Ti Hall Of Fame, 11GB GDDR5X | 1x Crucial M500 240GB | 1x Crucial MX300 525GB | Windows 10 Pro 64-Bit
    • see my picture. in the webinterface is the seetings disable.
      Images
      • Bildschirmfoto von 2019-03-03 13-43-49.png

        158.28 kB, 1,600×900, viewed 48 times
      PC: CaseLabs Mercury S3 | Intel Core i5-4670K 4x 3.40GHz | 16GB DDR3-2133 MHz Corsair Dominator Platinum | KFA² GeForce GTX 1080 Ti Hall Of Fame, 11GB GDDR5X | 1x Crucial M500 240GB | 1x Crucial MX300 525GB | Windows 10 Pro 64-Bit
    • yes i have, but my root directory is not /dev/root. in the fstab is my root directory /dev/mmcblk0p2, why is this directory not in the webinterface to see?

      Source Code

      1. root@Server:~# df
      2. Filesystem 1K-blocks Used Available Use% Mounted on
      3. /dev/root 30543972 3734396 26455992 13% /
      4. devtmpfs 495480 0 495480 0% /dev
      5. tmpfs 500088 0 500088 0% /dev/shm
      6. tmpfs 500088 13352 486736 3% /run
      7. tmpfs 5120 4 5116 1% /run/lock
      8. tmpfs 500088 0 500088 0% /sys/fs/cgroup
      9. tmpfs 500088 2380 497708 1% /tmp
      10. /dev/mmcblk0p1 63503 22397 41107 36% /boot
      11. folder2ram 500088 19340 480748 4% /var/log
      12. folder2ram 500088 0 500088 0% /var/tmp
      13. folder2ram 500088 472 499616 1% /var/lib/openmediavault/rrd
      14. folder2ram 500088 20 500068 1% /var/spool
      15. folder2ram 500088 12472 487616 3% /var/lib/rrdcached
      16. folder2ram 500088 8 500080 1% /var/lib/monit
      17. folder2ram 500088 0 500088 0% /var/lib/php
      18. folder2ram 500088 0 500088 0% /var/lib/netatalk/CNID
      19. folder2ram 500088 420 499668 1% /var/cache/samba
      20. /dev/sda1 3907017540 942247700 2963267532 25% /srv/dev-disk-by-label-Datenspeicher
      21. tmpfs 100016 0 100016 0% /run/user/0
      Display All
      Here my fstab

      Source Code

      1. cat /etc/fstab
      2. proc /proc proc defaults 0 0
      3. /dev/mmcblk0p1 /boot vfat defaults 0 2
      4. /dev/mmcblk0p2 / ext4 noatime,nodiratime,errors=remount-ro 0 1
      5. #/var/swap none swap sw 0 0
      6. # >>> [openmediavault]
      7. /dev/disk/by-label/Datenspeicher /srv/dev-disk-by-label-Datenspeicher btrfs defaults,nofail 0 2
      8. # <<< [openmediavault]
      9. tmpfs /tmp tmpfs defaults 0 0
      PC: CaseLabs Mercury S3 | Intel Core i5-4670K 4x 3.40GHz | 16GB DDR3-2133 MHz Corsair Dominator Platinum | KFA² GeForce GTX 1080 Ti Hall Of Fame, 11GB GDDR5X | 1x Crucial M500 240GB | 1x Crucial MX300 525GB | Windows 10 Pro 64-Bit
    • CaparZo wrote:

      yes i have, but my root directory is not /dev/root. in the fstab is my root directory /dev/mmcblk0p2, why is this directory not in the webinterface to see?
      Sometimes it detects the root drive incorrectly. The good thing is it doesn't matter since it is only used to show the number of bytes written since boot to the root filesystem. This is a display only and doesn't affect the how the plugin works. The output you posted shows that flashmemory is working.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!