Login issue

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Login issue

      Hi there,

      A friend has setup majority of my plex media server running through a pi. Seeing the back and how it's configured etc I have a little understanding of how it's put together now.

      After having no issues logging in I have started experiencing this on log in:

      Error #0:OMV\Rpc\Exception: Failed to connect to socket: Connection refused in /usr/share/php/openmediavault/rpc/rpc.inc:140Stack trace:#0 /var/www/openmediavault/rpc/session.inc(56): OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)
      #1 [internal function]: OMVRpcServiceSession->login(Array, Array)
      #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
      #4 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
      #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
      #6 {main}

      Anyone assist with a fix or cause?
    • Try opening your browser in Privacy/Incognito mode, and then log in to the webUI. A lot of errors like that are caused by a cache issue.

      If logging in in Incognot/Privacy mode works normally, then you know it's a cache issue.

      With Google Chrome, go to the omv sign on screen, hold Control and Click the Refresh button (or hit F5).. and that should clear the cache for the OMV webui.
      Air Conditioners are a lot like PC's... They work great until you open Windows.

    • EchoZ wrote:

      Failed to connect to socket: Connection refused
      This indicates that the omv-engined process is not running.

      Try to start it manually to check if there are errors:


      1. $ monit stop omv-engined
      2. $ omv-engined -d -f

      If there are no errors, then restart it again with


      1. $ monit restart omv-engined
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Hello,
      I encountered the exact same issue. I tried the solutions above but none of them worked.
      If I try to restart the engine, the output is:

      Source Code

      1. Cannot create socket to [localhost]:2812 -- Connection refused

      I I type omv-engined -d -f following happens:

      Source Code

      1. PHP Fatal error: require_once(): Failed opening required 'openmediavault/object.inc' (include_path='.:/usr/share/php') in /usr
      2. /share/openmediavault/engined/rpc/shellinabox.inc on line 22

      5min after I made the post I somehow realised that the shellinabox plugin is the issue.

      I purged it with:

      apt-get purge shellinabox

      Have a nice day!

      The post was edited 2 times, last by deonixlive ().