What could have happened to my NextCloud access

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • What could have happened to my NextCloud access

      Been running NextCloud on my test machine for a few days now without any problems. Last night before shutting it down, there was a list of OMV updates that I installed in the update manager. Shut the server down for the night and turned it back on this morning. Now I get a 502 Bad Gateway ngnix error when trying to connect to Next Cloud thru duckdns. I didn't touch a single setting on anything other than installing the updates.

      Could one of the updates have hosed my NextCloud installation? If not, would anyone have any suggestions on what to look for to try and resolve this because I am clueless, especially since it was working perfectly for three days. I did revert back to the settings for using just local access just to see if it would load and it does so the cloud setup still seems intact. It seems to be something related to the duckdns setup, but I am at a loss since I didn't change any settings.
    • No, it is running thru docker. I followed the tutorial on youtube by Techno Dad. Should I have done it another way instead?

      EDIT: I got it worked out. Basically I just removed everything and reinstalled. Thankfully it was just a test machine and I didn't have anything important on NextCloud yet that I worried about losing. Going to keep running the test server for a few more days and make sure it doesn't happen again. Never did discover what the cause was.

      The post was edited 1 time, last by flyinjoe13 ().

    • I assume that you are also using the letsencrypt docker...

      You have to edit your nextcloud.subdomains.conf in the letsencrypt config files -> yourconfigfolder/nginx/proxy-confs/

      and add

      Source Code

      1. add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";
      inside the "server {" block

      EDIT: restart your letsencrypt and nextcloud dockers afterwards.
      EDIT 2: regarding the argument "preload;" at the end please consider this link first and remove it if you don't want this option.

      found this solution here

      The post was edited 1 time, last by Morlan ().