VLAN and static routes

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • VLAN and static routes

      I was able to finally get access to my VLAN interface on my OMV4 machine. Just for clarification, I placed OMV4 on my Proxmox host, and initially I was having issue creating the VLAN interface, but recently was able to ssh into the VLAN interface. The problem that I am having is getting a static route out. I have tried using the web interface as well as command line and no bueno.

      ens18 --> [VLAN30] # Primary OMV4 interface
      ens18.40 --> {VLAN40] # Docker VLAN


      1. root@fs-01:/etc/network/interfaces.d# ip a
      2. 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
      3. link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      4. inet scope host lo
      5. valid_lft forever preferred_lft forever
      6. inet6 ::1/128 scope host
      7. valid_lft forever preferred_lft forever
      8. 2: ens18: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
      9. link/ether ca:74:2c:26:38:12 brd ff:ff:ff:ff:ff:ff
      10. inet brd scope global ens18
      11. valid_lft forever preferred_lft forever
      12. 4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
      13. link/ether 02:42:b0:92:a3:92 brd ff:ff:ff:ff:ff:ff
      14. inet brd scope global docker0
      15. valid_lft forever preferred_lft forever
      16. 11: ens18.40@ens18: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
      17. link/ether ca:74:2c:26:38:12 brd ff:ff:ff:ff:ff:ff
      18. inet brd scope global ens18.40
      19. valid_lft forever preferred_lft forever
      20. root@fs-01:/etc/network/interfaces.d# ip route list
      21. default via dev ens18
      22. dev docker0 proto kernel scope link src linkdown
      23. dev ens18 proto kernel scope link src
      24. via dev ens18.40
      Display All

      I am able to ssh to the interface with no problems. But when connected to OVM, if I attempt to ssh to a host on my network, the command hangs. Also, I am not able to ping any host on my network. Interestingly enough, I can apt-get update and upgrade, so I am able to resolve names. I also noticed that my docker0 ( interface is down as well. Granted that I would rather my docker containers worked on the network, but it would be nice if the docker0 interface bridge worked as well. I have setup ip forwarding and iptables:


      1. root@fs-01:~# sysctl net.ipv4.conf.all.forwarding=1
      2. net.ipv4.conf.all.forwarding = 1
      3. root@fs-01:~# iptables -P FORWARD ACCEPT
      But still no change. Any suggestions would be greatly appreciated.