physical disk properties Standby error

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • physical disk properties Standby error

      Hallo OMV,
      Ich betreibe OMV 4.1.19-1 auf einem RockPro64 mit der PCI-e to Dual SATA-II Interface Card und einer HDD Seagate IronWolf
      HDD Seagate IronWolf Information



      Source Code

      1. === START OF INFORMATION SECTION ===
      2. Model Family: Seagate IronWolf
      3. Device Model: ST4000VN008-2DR166
      4. Serial Number: ZDH36NNE
      5. LU WWN Device Id: 5 000c50 0afc5c4f5
      6. Firmware Version: SC60
      7. User Capacity: 4,000,787,030,016 bytes [4.00 TB]
      8. Sector Sizes: 512 bytes logical, 4096 bytes physical
      9. Rotation Rate: 5980 rpm
      10. Form Factor: 3.5 inches
      11. Device is: In smartctl database [for details use: -P show]
      12. ATA Version is: ACS-3 T13/2161-D revision 5
      13. SATA Version is: SATA 3.1, 6.0 Gb/s (current: 3.0 Gb/s)
      14. Local Time is: Sat Mar 16 11:31:29 2019 CET
      15. SMART support is: Available - device has SMART capability.
      16. SMART support is: Enabled
      17. AAM feature is: Unavailable
      18. APM level is: 127 (intermediate level with standby)
      19. Rd look-ahead is: Enabled
      20. Write cache is: Enabled
      21. ATA Security is: Disabled, NOT FROZEN [SEC1]
      22. Wt Cache Reorder: Enabled
      Display All





      Mein Problem: Die Festplatte wechselt zu schnell in Standby Modus. Es dauert ca. 10/15 min. manchmal auch schneller 3/5 min. und die Festplatte wechselt wieder in Standby Modus obwohl 120 min. in physical disk properties eingestellt ist.

      Achte auf Datum / Uhrzeit. Festplatte sdb wechselt nach ca. 12 min. in Standbay Modus. :cursing:

      Source Code

      1. hddtemp /dev/sdb hddtemp /dev/sda
      2. --------- Sat Mar 16 12:26:26 CET 2019 ------------
      3. /dev/sdb: ST4000VN008-2DR166: drive is sleeping
      4. /dev/sda: WDC WD5000LUCT-63RC2Y0: 37 C
      5. -------------------------------------------------------------
      6. --------- Sat Mar 16 12:26:59 CET 2019 ------------
      7. /dev/sdb: ST4000VN008-2DR166: 34 C
      8. /dev/sda: WDC WD5000LUCT-63RC2Y0: 37 C
      9. -------------------------------------------------------------
      10. --------- Sat Mar 16 12:38:02 CET 2019 ------------
      11. /dev/sdb: ST4000VN008-2DR166: drive is sleeping
      12. /dev/sda: WDC WD5000LUCT-63RC2Y0: 34 C
      Display All


      Andere Konsole Ausgabe:

      Source Code

      1. nano /etc/hdparm.conf
      2. quiet
      3. /dev/disk/by-id/ata-ST4000VN008-2DR166_ZDH36NNE {
      4. apm = 127
      5. spindown_time = 244
      6. write_cache = on
      7. }
      8. /dev/disk/by-id/ata-WDC_WD5000LUCT-63RC2Y0_WD-WX51A56LUFRX {
      9. apm = 127
      10. spindown_time = 242
      11. write_cache = on
      12. }
      13. ---------------------------------------------------------------------
      14. dpkg -l | grep hdparm
      15. ii hdparm 9.51+ds-1+deb9u1 armhf tune hard disk parameters for high performance
      16. ---------------------------------------------------------------------
      17. sudo hdparm -y /dev/sdb
      18. /dev/sdb:
      19. issuing standby command
      20. ---------------------------------------------------------------------
      21. sudo hdparm -I /dev/sdb | grep 'Write cache'
      22. * Write cache
      Display All


      Bisherige versucht: Ein/Aus, wechselt der Spindown time in OMV physical disk properties auch immer wieder Neustart. KEIN ERGEBNIS.
      Somit wird die Lebensdauer verkürzt, wen der Festplatte immer wieder in Standbay Modus nach einer kurzer Zeit wechselt.
      Wo ist der Fehler, wie kann man es beheben? Bitte Hilfe!
      Vielen Dank.
      Images
      • disks-omv-einst..JPG

        41.21 kB, 586×400, viewed 229 times
      | OMV 4.1.21-1 Arrakis | RockPro64 4GB | Debian GNU/Linux 9 (stretch) | ARMv8 Processor rev 4 (v8l) | Linux 4.4.167-1161-rockchip-ayufan-g6f1664023387 |
    • macom wrote:

      Vielleicht gibt es auf der SATA-Karte eine Firmware, die die Platten in Standby schickt.
      Ich weiß es nicht, aber warum wird die zweite Festplatte > /dev/sda: WDC WD5000LUCT-63RC2Y0 mit fast den selben Einstellungen in physical disk properties nicht in Standby versetzt? Merkwürdig.

      macom wrote:

      Schau/frag mal im Pine64 Forum nach.
      Ein neues Thema / Anfrage im PINE64 Forum habe ich erstellt.
      Danke, ich hoffe es Antwortet jemand.
      | OMV 4.1.21-1 Arrakis | RockPro64 4GB | Debian GNU/Linux 9 (stretch) | ARMv8 Processor rev 4 (v8l) | Linux 4.4.167-1161-rockchip-ayufan-g6f1664023387 |
    • physical disk properties Standby error

      macom wrote:

      Falls keine bessere Idee kommt, könntest du noch hdparm deaktivieren und statt dessen hd-idle testen.

      Wie erwartet erhielt ich keine Antwort in dem "toten" Forum.
      Die einzige Antwort von einem guten Menschen vermutet das es am APM modes 127 liegt oder OMV Überwachens Tools was damit zu tun haben.
      Antwort aus PINE64 Forum

      Hello,


      The APM mode 127, sends the disk in standby, relatively fast..
      I don't know if you remember that I asked you about if you had something else Running from the IronWolf disk?


      Usually, the best Thing is maintaining it only for Data, without Os and so..
      Because if not, the disk will be waked constantly, reducing its life time (load/unload heads counts..)..


      This has nothing to do with the PCIe card, or with the timers on the disk..
      The timers by default are very nice, Seagate disks behave usually nicer in that regard..


      If a disk is sleeping, and you issue some monitoring command on Him, it
      will wakeup, and I think this his the behaviour you are experiencing..


      Maybe OMV is doing monitoring too much..
      Try to use its corresponding SCSI counterpart, /dev/sgx, this can work
      for some commands, and doesn't usually wakeup the disks, but its more
      limited than query the /dev/sdX..


      Maybe this is the problem..

      Jetzt habe ich SMART für die Festplatte komplett deaktiviert und auf 128 gesetzt. > Keine Auswirkung gleiche Problem.
      Nach 2min wird in Standby Modus gewechselt

      Brainfuck Source Code

      1. hddtemp /dev/sdb hddtemp /dev/sda
      2. :~# sh a.sh
      3. --------- Tue Mar 19 11:46:50 CET 2019 ------------
      4. /dev/sdb: ST4000VN008-2DR166: 34 C
      5. /dev/sda: WDC WD5000LUCT-63RC2Y0: 36 C
      6. :~# sh a.sh
      7. --------- Tue Mar 19 11:48:00 CET 2019 ------------
      8. /dev/sdb: ST4000VN008-2DR166: drive is sleeping
      9. /dev/sda: WDC WD5000LUCT-63RC2Y0: 35 C
      Display All


      Welches Tool steuert die Festplatten? Oder hat Seagate HDD seine eigene Regel zum steuern an/aus etc?
      Wenn das so weiter geht wird die Festplatte nicht mehr lange durchhalten.
      | OMV 4.1.21-1 Arrakis | RockPro64 4GB | Debian GNU/Linux 9 (stretch) | ARMv8 Processor rev 4 (v8l) | Linux 4.4.167-1161-rockchip-ayufan-g6f1664023387 |
    • Hallo,

      du könntest vielleicht mal versuchen, den APM-Mode auf einen Wert größer 127 zu stellen. Bis zu einem Wert von 127 bringt nämlich der APM-Mode die Platte in den Standby und zwar unabhängig von der konfigurierten Spin Down time. So verstehe ich das zumindest. Alle Werte größer 127 sind ohne Standby. Den Standby macht dann der hdparm.

      Das fand ich ganz interessant: Fix the hard drive killer APM
      OMV 3.0.90 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • cabrio_leo wrote:

      du könntest vielleicht mal versuchen, den APM-Mode auf einen Wert größer 127 zu stellen. Bis zu einem Wert von 127 bringt nämlich der APM-Mode die Platte in den Standby und zwar unabhängig von der konfigurierten Spin Down time. So verstehe ich das zumindest. Alle Werte größer 127 sind ohne Standby. Den Standby macht dann der hdparm.

      Test Nr1: Der wert wurde auf 128 gesetzt (128 = Minimaler Energieverbrauch ohne Bereitschaft (kein Spindown)) Spin Down Time deaktieviert. SMART ist deaktiviert. Neu Start.
      Ergebnis
      Nach 1 min. Wechsel in Standbay Modus.

      Brainfuck Source Code

      1. hddtemp /dev/sdb hddtemp /dev/sda
      2. :~# sh a.sh
      3. --------- Wed Mar 20 12:03:43 CET 2019 ------------
      4. /dev/sdb: ST4000VN008-2DR166: 34 C
      5. /dev/sda: WDC WD5000LUCT-63RC2Y0: 35 C
      6. :~# sh a.sh
      7. --------- Wed Mar 20 12:04:53 CET 2019 ------------
      8. /dev/sdb: ST4000VN008-2DR166: drive is sleeping
      9. /dev/sda: WDC WD5000LUCT-63RC2Y0: 35 C


      tkaiser wrote:

      Kurze Suche nach 'ironwolf hdparm' meint, man solle hdparm -B 254 setzen, dann klappt's auch mit dem Ding und hdparm -S sollte funktionieren wie erwartet.

      Test Nr2: Der wert wurde auf 254 gesetzt (254 = Maximale Leistung, maximaler Energieverbrauch) Spin Down Time 30min. SMART ist deaktiviert. Neu Start.
      Ergebnis
      Die Festplatte dreht mit Maximalen Leistung, Standbay Modus ist leider mit der Einstellung>254 AUS/DEAKTIEVIERT>
      Standby Modus ist deaktiviert in 254

      Brainfuck Source Code

      1. === START OF INFORMATION SECTION ===
      2. Model Family: Seagate IronWolf
      3. Device Model: ST4000VN008-2DR166
      4. ATA Version is: ACS-3 T13/2161-D revision 5
      5. AAM feature is: Unavailable
      6. .
      7. .
      8. .
      9. >>>>>>>>>>>>>>>>>>>>APM level is: 254 (maximum performance)<<<<<<<<<<<<<<<
      10. Rd look-ahead is: Enabled
      11. Write cache is: Enabled
      12. >>>>>>>>>>>>>>>>>>>>ATA Security is: Disabled, NOT FROZEN [SEC1]<<<<<<<<<<<<<<<
      13. Wt Cache Reorder: Enabled
      Display All




      Halbe 1Stunde 30Minuten Später kein Standby

      Brainfuck Source Code

      1. hddtemp /dev/sdb hddtemp /dev/sda
      2. :~# sh a.sh
      3. --------- Wed Mar 20 19:26:38 CET 2019 ------------
      4. /dev/sdb: ST4000VN008-2DR166: 32 C
      5. /dev/sda: WDC WD5000LUCT-63RC2Y0: 35 C
      6. :~# sh a.sh
      7. --------- Wed Mar 20 21:00:04 CET 2019 ------------
      8. /dev/sdb: ST4000VN008-2DR166: 32 C
      9. /dev/sda: WDC WD5000LUCT-63RC2Y0: 32 C

      | OMV 4.1.21-1 Arrakis | RockPro64 4GB | Debian GNU/Linux 9 (stretch) | ARMv8 Processor rev 4 (v8l) | Linux 4.4.167-1161-rockchip-ayufan-g6f1664023387 |
    • Test Nr3: Der wert wurde auf 192 gesetzt (192 = Durchschnittlicher Energieverbrauch ohne Bereitschaft) Spin Down Time 30min. SMART ist deaktiviert. Neu Start.
      Auch hier ist Spin Down time Standard mäßig deaktiviert
      Ergebnis
      Modus 192 Spin Down time Standard mäßig deaktiviert

      Brainfuck Source Code

      1. === START OF INFORMATION SECTION ===
      2. Model Family: Seagate IronWolf
      3. >>>>>>>>>>>>>>APM level is: 192 (intermediate level without standby)<<<<<<<<<<<<<
      4. Rd look-ahead is: Enabled
      5. Write cache is: Enabled
      6. >>>>>>>>>>>>>>ATA Security is: Disabled, NOT FROZEN [SEC1]<<<<<<<<<<<<<<<<<<
      7. Wt Cache Reorder: Enabled




      ca. 30 Minuten Später

      hddtemp /dev/sdb hddtemp /dev/sda
      r:~# sh a.sh
      --------- Wed Mar 20 21:15:21 CET 2019 ------------
      /dev/sdb: ST4000VN008-2DR166: 33 C
      /dev/sda: WDC WD5000LUCT-63RC2Y0: 32 C

      sh a.sh
      --------- Wed Mar 20 21:51:59 CET 2019 ------------
      /dev/sdb: ST4000VN008-2DR166: 33 C
      /dev/sda: WDC WD5000LUCT-63RC2Y0: 33 C


      Egal welche Einstellungen man verwendet, hdparm befähle werden nicht angenommen oder verwendet.

      tkaiser wrote:

      At least I would test directly with hdparm on the command line

      Auch das habe ich getestet. Kein unterschied. In /etc/hdparm.conf werden die Einstellungen korrekt Übernomen.
      nano /etc/hdparm.conf

      Source Code

      1. quiet
      2. /dev/disk/by-id/ata-ST4000VN008-2DR166_ZDH36NNE {
      3. apm = 192
      4. spindown_time = 241
      5. write_cache = on
      6. }
      7. /dev/disk/by-id/ata-WDC_WD5000LUCT-63RC2Y0_WD-WX51A56LUFRX {
      8. apm = 127
      9. spindown_time = 242
      10. write_cache = on
      11. }
      Display All


      tkaiser wrote:

      and try to continue in English

      I will try to write in English with the help of google translator. Sorry.
      | OMV 4.1.21-1 Arrakis | RockPro64 4GB | Debian GNU/Linux 9 (stretch) | ARMv8 Processor rev 4 (v8l) | Linux 4.4.167-1161-rockchip-ayufan-g6f1664023387 |
    • So... I ran into problems with HC2s, Ironwolf 12TB and physical disk properties. If I changed any of the physical disk properties the IronWolves got unmounted and wouldn't mount after reboot. And I couldn't fix it without having to reinstall from scratch or restore a backup of the rootfs to the SD card. I belive this was caused by hdparm. Hdparm caused the IronWolves to malfunction. I fixed it by simply not changing ANY of the physical disk properties. The default settings of the IronWolves were OK. And I could set the spindown timer by reflashing the SATA USB bridge firmware of the HC2, instead of using hdparm. After this, not using hdparm at all, my HC2s with IronWolves became nice and very well-behaved and fast doggies. And we live happily ever after...

      The default spindown timer of the IronWolves was 2-3 minutes. By reflashing the SATA USB firmware of th HC2 I could set it to 30 minutes. Or whatever I wanted.

      It took a couple days to figure out that skipping the physical disk properties altogether was the solution. And many backups and restores of the SD card.

      I don't know if this is a general problem or only (or extra bad) with the combination of HC2 and Ironwolf. I have seen posts online where others report problems using hdparm with newer NAS drives. Like WD Red and Ironwolf. Perhaps some hdparm settings are OK to use? I never figured it out. And I don't feel like I need to anymore.
      OMV 4, 7 x ODROID HC2, 1 x ODROID HC1, 5 x 12TB, 1 x 8TB, 1 x 2TB SSHD, 1 x 500GB SSD, GbE, WiFi mesh

      The post was edited 1 time, last by Adoby ().

    • Adoby wrote:

      After this, not using hdparm at all,
      Hello Adoby, thank you for your comment.
      What if I use a clean OMV without using hdparm. And immediately after mount the HDD, install or test OpenSeaChest / OpenSeaChest features. Accordingly, hdpart makes the problems and not PCI-e SATA-II Card.??
      or with another OS. (Which OS would be better suited?)?
      is this worth a try?
      | OMV 4.1.21-1 Arrakis | RockPro64 4GB | Debian GNU/Linux 9 (stretch) | ARMv8 Processor rev 4 (v8l) | Linux 4.4.167-1161-rockchip-ayufan-g6f1664023387 |
    • Adoby wrote:

      By reflashing the SATA USB firmware of th HC2 I could set it to 30 minutes. Or whatever I wanted.

      tkaiser wrote:

      No idea what's going on.

      cabrio_leo wrote:

      Den Standby macht dann der hdparm.

      macom wrote:

      Falls keine bessere Idee kommt, könntest du noch hdparm deaktivieren und statt dessen hd-idle testen
      Hello,
      A solution with standby - Spindown time settings I have not found unfortunately.
      My idea with the clearOS did not work either.
      The hard drive into a USB 3.0 external enclosure 3.5 and OpenSeaChest to instal after using OpenSeaChest features to control, also did not work.
      Whether problem at OMV, PCI-e SATA-II Card, or hdparm I can not determine.

      For me, I have now set the hdparm Advanced Power Management 192 option. (192 - Intermediate power usage without standby). This is the best setting for my needs. The hard drive automatically goes into standby mode after an "indefinite" time. Which time exactly I could not determine, but more than 30 min.
      It is very annoying that one can not adjust the Standby / Spindown time with hdparm.

      Maybe someone can tell me why I can not run OpenSeaChest, which blocks the usage. output>

      Source Code

      1. :~# openSeaChest_Basics --deviceInfo --device /dev/sdb
      2. ==========================================================================================
      3. openSeaChest_Basics - openSeaChest drive utilities - NVMe Enabled
      4. Copyright (c) 2014-2018 Seagate Technology LLC and/or its Affiliates, All Rights Reserved
      5. openSeaChest_Basics Version: 2.8.0-1_19_0 ARM
      6. Build Date: Feb 28 2019
      7. Today: Sat Mar 2 11:38:54 2019
      8. ==========================================================================================
      9. open: Bad address
      10. open failure
      11. Error: 14 - Bad address
      12. Error: Could not open handle to /dev/sdb
      Display All
      Many thanks for the support.
      | OMV 4.1.21-1 Arrakis | RockPro64 4GB | Debian GNU/Linux 9 (stretch) | ARMv8 Processor rev 4 (v8l) | Linux 4.4.167-1161-rockchip-ayufan-g6f1664023387 |

      The post was edited 1 time, last by M0rpheus ().