Pull older docker image version

    • OMV 4.x
    • Pull older docker image version

      Plex has stopped transcoding my .mkv files all of a sudden. It worked as early as last night because I watched a movie. The only thing I noticed was that my version went from 1.14.something to 1.15.something. I wanted to see if it was the update that did it by removing plex all together and installing the previous version, but I don't know if that is possible. Can you force pull an older version and if so, how?

      Thanks...

      EDIT: I think I know how to do it, but I don't know exactly how to enter it in the environment variables section. I have to add a VERSION entry, but I don't know the full number for the last version. Version 1.14.1.5488 worked, now I am on version 1.15.1.793. I need to force version 1.14.1.5488 in the variables but when I do, it doesn't work. I think there some more numbers to the version that I don't know based on the info page directions.

      EDIT2: I got it. I found the correct full version number and added it to the Tag line. Unfortunately, it did not solve my transcode issue. Not exactly sure what happened here since it worked last night. Guess I will be busy tonight trying to figure it out.

      The post was edited 4 times, last by flyinjoe13 ().

    • My knowledge of Plex is pretty limited as I just experimented with it for a month. Curious, which Plex docker did you install? Linuxserver, or the official Plex? I had a lot of issues w/ the official Plex container, but none with the Linuxserver one... I'm sure this was something I was doing wrong, but, it is what it is.

      One thing to note (I signed up for Plex pass for a month)... You can set the version it will maintain on in the environments...

      hub.docker.com/r/linuxserver/plex/

      Source Code

      1. docker create \
      2. --name=plex \
      3. --net=host \
      4. -e PUID=1000 \
      5. -e PGID=1000 \
      6. -e VERSION=docker \
      7. -v </path/to/library>:/config \
      8. -v <path/to/tvseries>:/data/tvshows \
      9. -v </path/to/movies>:/data/movies \
      10. -v </path for transcoding>:/transcode \
      11. --restart unless-stopped \
      12. linuxserver/plex
      Display All


      Note the "Version" in line 6.

      Further on down..

      Source Code

      1. ** For new users, no updates will take place on the first run of the container as there is no preferences file to read your token from, to update restart the Docker container after logging in through the webui**
      2. Valid settings for VERSION are:-
      3. IMPORTANT NOTE:- YOU CANNOT UPDATE TO A PLEXPASS ONLY (BETA) VERSION IF YOU ARE NOT LOGGED IN WITH A PLEXPASS ACCOUNT
      4. docker: Let Docker handle the Plex Version, we keep our Dockerhub Endpoint up to date with the latest public builds. This is the same as leaving this setting out of your create command.
      5. latest: will update plex to the latest version available that you are entitled to.
      6. public: will update plexpass users to the latest public version, useful for plexpass users that don't want to be on the bleeding edge but still want the latest public updates.
      7. <specific-version>: will select a specific version (eg 0.9.12.4.1192-9a47d21) of plex to install, note you cannot use this to access plexpass versions if you do not have plexpass.
      Display All
      Not sure if that helps, but maybe it will give you something to check.
      Air Conditioners are a lot like PC's... They work great until you open Windows.

    • flyinjoe13 wrote:

      Plex has stopped transcoding my .mkv files all of a sudden. It worked as early as last night because I watched a movie. The only thing I noticed was that my version went from 1.14.something to 1.15.something. I wanted to see if it was the update that did it by removing plex all together and installing the previous version, but I don't know if that is possible. Can you force pull an older version and if so, how?

      Thanks...

      EDIT: I think I know how to do it, but I don't know exactly how to enter it in the environment variables section. I have to add a VERSION entry, but I don't know the full number for the last version. Version 1.14.1.5488 worked, now I am on version 1.15.1.793. I need to force version 1.14.1.5488 in the variables but when I do, it doesn't work. I think there some more numbers to the version that I don't know based on the info page directions.

      EDIT2: I got it. I found the correct full version number and added it to the Tag line. Unfortunately, it did not solve my transcode issue. Not exactly sure what happened here since it worked last night. Guess I will be busy tonight trying to figure it out.

      Woops, didn't see your edits.

      Regardless... if you've already upgraded, I don't think setting the version to a lower number is going to "downgrade" you after you've updated.
      Air Conditioners are a lot like PC's... They work great until you open Windows.

    • Whatever my problem is has nothing to do with version numbers, but I appreciate the info. I spent 4 hours trying to figure it out until I finally gave up. Not sure what happened. I ripped a movie last night and watched it without a problem. Shut the server down for the night, turned it on this evening after work, ripped another movie and it won't play. I literally changed nothing on the server. Even completely removing plex and starting from scratch doesn't work. Whatever it is is beyond me.

      I plan to take another usb drive and load a clean copy of omv tomorrow and see if plex works. At least then I will know if it's my hardware or something with my omv configuration.

      The post was edited 1 time, last by flyinjoe13 ().

    • Were you streaming .mkv files? My MP4's work fine. MKV files will not transcode in Plex sometimes if you have the noexec opt enabled in config.xml.

      The movie I watched the other night was an mp4. Last night's was an .mkv because I didn't want to take the time to convert it. I had removed the noexec opt on my test machine, but this was my actual server I was streaming from that I had just put together and forgot about removing that option. Like I said, 4 hours wasted for a 2 minute fix. That's what happens when you are a newbie. :)
    • flyinjoe13 wrote:

      Were you streaming .mkv files? My MP4's work fine. MKV files will not transcode in Plex sometimes if you have the noexec opt enabled in config.xml.

      The movie I watched the other night was an mp4. Last night's was an .mkv because I didn't want to take the time to convert it. I had removed the noexec opt on my test machine, but this was my actual server I was streaming from that I had just put together and forgot about removing that option. Like I said, 4 hours wasted for a 2 minute fix. That's what happens when you are a newbie. :)
      I have lots of .mkv's.. so I'm assuming I watched a few while trying Plex and/or Emby.

      I ended up just going back to Kodi on my Shield and just point it at a couple of smb shares. No transcoding, etc.. and honestly, I really like Kodi interface compared to the other two. Since my iptv service has a Kodi add on, I can usually do everything I want to do right from Kodi and really don't use the "Shield" features very often
      Air Conditioners are a lot like PC's... They work great until you open Windows.

      The post was edited 1 time, last by KM0201 ().