Wake-on LAN not working

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Wake-on LAN not working

      Hi all,

      sorry first of all, but I already added a similar post to a hardware forum but I now think it's more a software problem and I hope you have experiences and can better help me.

      I use a Dell T30 and activated wake on lan in the bios and deactivated deep sleep. Then I adusted OMV's web gui in network -> interfaces to enable WOL. I now also restarted manually several times,...

      I checked the led on my lan plug and it's switched on, even if the T30 is shutdown. Then I opened the shell and typed

      ethtool <NIC>

      and saw

      ...
      Supports Wake-on: pumbg Wake-on: g...Then I checked the /etc/network/interfaces and saw the pre-down entries. So also this looked good.Nevertheless, when I now run wol.exe with the commandwol.exe 12:23:45:67:89:10 /d 10.50.50.10The packet is sent, but the server doesn't wake up. When I run the commandwol.exe 12:23:45:67:89:10 /d 10.50.50.10-> it doesn't matter, if the server is running or not, I get the following message:No internal networking adapter has the IP address 10.50.50.10-> Is this normal?Does anyone have an idea what I'm doing wrong?

      Thanks!
      Kind regards,

      Felix
    • FeBo2 wrote:

      Does anyone have an idea what I'm doing wrong?
      I would only send the mac address. The magic packet that is sent to wake the system up is layer 2 which is below the IP address layer 3 anyway.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Good morning ryecoaaron,

      thanks for your response. I now only sent the mac address and the packet has successfully been sent. Nevertheless the server doesn't start. I tried it several times, also with MagicPacket and WoL2.

      In the DELL bios I have to possibility to Wake on LAN into "LAN Only" and "LAN PXE". As far as I understood PXE is a possibility to remote control / administrate the server before the regular OS started, so I don't need it, but nevertheless I tried both options after another and sending magic packets to the mac address. I again controlled the led on the network interface, which is still on.

      Any idea, what I can check / are there any logs for Wake on LAN? Probably not at that point when the server is switched off and only the network interface is listening?!

      Thanks!
      Kind regards,

      Felix
    • FeBo2 wrote:

      As far as I understood PXE is a possibility to remote control / administrate the server before the regular OS started, so I don't need it
      Nope. PXE is remote booting an OS image so that it doesn't need to be installed on the local system.

      FeBo2 wrote:

      Any idea, what I can check / are there any logs for Wake on LAN?
      While I have a desktop that I use wakeonlan with, I have never used that on any of the many Dell servers I have had. Looking at this, it looks like your adapter may have an energy efficient setting that needs to be disabled for WOL to work.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hi ryceoaaron,

      thanks for your response.

      ryecoaaron wrote:


      Nope. PXE is remote booting an OS image so that it doesn't need to be installed on the local system.
      Thanks for clarification.

      ryecoaaron wrote:

      While I have a desktop that I use wakeonlan with, I have never used that on any of the many Dell servers I have had. Looking at this, it looks like your adapter may have an energy efficient setting that needs to be disabled for WOL to work.
      I read this and the page you linked was the one I used to make the dell specific adjustments. But since OMV is debian based I thought this was only a Windows issue to disable the Energy Efficienct Ethernet Setting. I found this response now unix.stackexchange.com/questio…et-eee-aka-green-ethernet and will try at home if I can disable it that way or if there's a need / another way disabling it under linux.

      Thanks!
      Kind regards,

      Felix