Error When Checking For Updates

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Error When Checking For Updates

      as the title says. I'm getting an error every time I check for updates. its been like this for at least a few weeks.
      I've tried disabling all the repos and updating with no change.

      Thanks guys

      Source Code

      1. Error #0:
      2. exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; apt-get update 2>&1' with exit code '100': Ign file: InRelease
      3. Ign file: Release.gpg
      4. Ign file: Release
      5. Ign file: Translation-en
      6. Ign http://ftp.us.debian.org jessie InRelease
      7. Hit http://ftp.us.debian.org jessie-updates InRelease
      8. Hit http://ftp.us.debian.org jessie Release.gpg
      9. Hit http://ftp.us.debian.org jessie Release
      10. Get:1 http://ftp.us.debian.org jessie/main Sources [7063 kB]
      11. Hit http://security.debian.org jessie/updates InRelease
      12. Get:2 http://security.debian.org jessie/updates/main Sources [305 kB]
      13. Hit http://packages.openmediavault.org erasmus InRelease
      14. Get:3 http://security.debian.org jessie/updates/contrib Sources [1439 B]
      15. Get:4 http://security.debian.org jessie/updates/non-free Sources [1631 B]
      16. Ign http://httpredir.debian.org jessie-backports InRelease
      17. Get:5 http://ftp.us.debian.org jessie/main amd64 Packages [6818 kB]
      18. Get:6 http://security.debian.org jessie/updates/main amd64 Packages [664 kB]
      19. Get:7 http://security.debian.org jessie/updates/contrib amd64 Packages [2506 B]
      20. Get:8 http://security.debian.org jessie/updates/non-free amd64 Packages [4556 B]
      21. Ign http://httpredir.debian.org jessie-backports Release.gpg
      22. Hit http://packages.openmediavault.org erasmus/main amd64 Packages
      23. Get:9 http://ftp.us.debian.org jessie/main Translation-en [4581 kB]
      24. Get:10 http://security.debian.org jessie/updates/contrib Translation-en [1211 B]
      25. Get:11 http://security.debian.org jessie/updates/main Translation-en [335 kB]
      26. Ign http://httpredir.debian.org jessie-backports Release
      27. Get:12 http://security.debian.org jessie/updates/non-free Translation-en [11.8 kB]
      28. Ign http://packages.openmediavault.org erasmus/main Translation-en
      29. Err http://httpredir.debian.org jessie-backports/main amd64 Packages
      30. 404 Not Found
      31. Err http://httpredir.debian.org jessie-backports/contrib amd64 Packages
      32. 404 Not Found
      33. Err http://httpredir.debian.org jessie-backports/non-free amd64 Packages
      34. 404 Not Found
      35. Ign http://httpredir.debian.org jessie-backports/contrib Translation-en
      36. Ign http://httpredir.debian.org jessie-backports/main Translation-en
      37. Ign http://httpredir.debian.org jessie-backports/non-free Translation-en
      38. Fetched 18.5 MB in 5s (3636 kB/s)
      39. W: Failed to fetch http://ftp.us.debian.org/debian/dists/jessie-updates/InRelease Unable to find expected entry 'main/source/Sources' in Release file (Wrong sources.list entry or malformed file)
      40. W: Failed to fetch http://httpredir.debian.org/debian/dists/jessie-backports/main/binary-amd64/Packages 404 Not Found
      41. W: Failed to fetch http://httpredir.debian.org/debian/dists/jessie-backports/contrib/binary-amd64/Packages 404 Not Found
      42. W: Failed to fetch http://httpredir.debian.org/debian/dists/jessie-backports/non-free/binary-amd64/Packages 404 Not Found
      43. E: Some index files failed to download. They have been ignored, or old ones used instead.' in /usr/share/openmediavault/engined/rpc/apt.inc:219
      44. Stack trace:
      45. #0 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMVRpcServiceApt->{closure}('/tmp/bgstatusYe...', '/tmp/bgoutputDw...')
      46. #1 /usr/share/openmediavault/engined/rpc/apt.inc(223): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      47. #2 [internal function]: OMVRpcServiceApt->update(NULL, Array)
      48. #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      49. #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('update', NULL, Array)
      50. #5 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Apt', 'update', NULL, Array, 1)
      51. #6 {main}
      Display All
    • gderf wrote:

      You should indicate which version of OMV you are using. If you are on OMV 3.x, that's been EOL for a while and you should expect difficulties of the type you are having.
      I definitely suck when it comes to upgrading to a new version. I have everything Irreplaceable backed up, and most of my media just not ALL of it and not a whole lot of time lately to do the update/troubleshoot when it comes to setting / fixing stuff that isn't working properly after the update.

      KM0201 wrote:

      Yeah, there's only like 12 threads on this... maybe more.
      I suck at this too. I as looking for my old threads when i thought I had the same issue previously. I tried updating the omv extras repo. I didn't take as much time as I should have to properly search.

      Thanks guys
    • Users Online 1

      1 Guest