Enable cifs UNIX extensions on mount

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Enable cifs UNIX extensions on mount

      Hello

      I would like to activate cifs UNIX extensions on client mount.
      cifs UNIX extensions on smb.conf is active.
      (unix extensions = yes)

      On mount there is no cifs UNIX extensions visible as active.
      (nounix)

      On my understanding:

      User on client and server must have the same UID and GID.

      Client user: UID=1000 and GID=1000.

      The permanent change for the user on OMV to GID=1000 is not possible.

      Users on OMV generated on web access usually have GID=100
      Users on OMV generated on command line starts with GID=1000

      I can add a new user with useradd. Then my user have GID=1000

      To syncronize the user with config.xml and samba daemon, it is needed
      to update the new user on omv web access.

      After this the new user GID=100 again and
      cifs UNIX extensions are not enabled.

      What is the right way to enable cifs UNIX extensions stable?


      Thank you much

      The post was edited 1 time, last by konfuziuskus ().

    • konfuziuskus wrote:

      What is the right way to enable cifs UNIX extensions stable?
      Unix extensions are enabled by default in OMV's samba config file- github.com/openmediavault/open…conf/samba.d/10global#L47
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • konfuziuskus wrote:

      But only if client user UID/GID and server user UID/GID are the same.
      This is my problem. I can't setup the server user GID permanent to
      GID=1000. If i update my user on OMV do to update also the samba daemon settings,
      the GID change back to GID=100 an then Unix extensions are not enabled on mount on

      client side.
      Not the best solution but you could force a UID/GID for the share with the force user and force group in the extra options box for the share.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!