Nach OMV Installation auf QNAP TS-209 keine Netzwerkverbindung mehr zum NAS

    • OMV 3.x
    • Nach OMV Installation auf QNAP TS-209 keine Netzwerkverbindung mehr zum NAS

      Hallo zusammen,

      ich habe gerade auf meinem alten QNAP TS-209 Debian 8 und OMV3 aufgespielt - OMV nach dieser Anleitung:
      Install OMV3 on Debian Jessie

      Hat auch alles geklappt, nachdem ich das NAS dann heruntergefahren habe und heute wieder eingeschaltet bootet es zwar, jedoch geht kurz vor dem "Beep" das es hochgefahren ist die Ethernet LED an der Vorderseite aus - auch stundenlanges warten ändert hier nichts.

      Wie kann ich wieder auf das NAS zugreifen?
      Gibt es einen Trick, ich kann auf die Platte über ein anderes Linux System zugreifen und Dateien bearbeiten, falls das hilft.
    • Freak1711 wrote:

      ich habe gerade auf meinem alten QNAP TS-209 Debian 8 und OMV3 aufgespielt
      OMV3 is already EOL and as such you entered 'unsupported area'. In case you manage to install Debian 9 and OMV4 please be aware that your NAS is based on a horribly outdated ARM926EJ CPU (single core, 500 MHz) and as such will be dog slow (especially if you don't apply the few optimizations we do on the OMV images for ARM devices).

      Wrt random errors... since the hardware is most probably 10 years or older it's a bit pointless to diagnose stuff searching for software issues when it's maybe just 'hardware reaching EOL'...
    • cabrio_leo wrote:

      Für die ARM-Architekturen gibt es eigene, speziell angepasste Distributionen, die auch OMV enthalten. Möglichweise klappt ein Installationsversuch mit denen besser.
      Definitiv nicht. Wie man Debian 9 auf das Uralt-NAS bekommt, hab ich oben verlinkt (bringt aber wohl nix). Macht aber überhaupt keinen Sinn mehr speziell mit Geräten, die weder Bildschirmausgabe noch serielle Konsole haben. Wenn da irgendwas nicht geht (speziell kein Netzwerk mehr), dann kann man nur rätseln, was auf reine Zeitverschwendung rausläuft.

      The post was edited 1 time, last by tkaiser ().

    • Hm, man könnte mal schauen, ob ein dhcp client läuft. Ich weiß nicht, welcher Netzwerkmanager unter der Version Standard ist, vielleicht noch dhcpcd, oder doch schon NetworkManager, oder eine der vielen anderen Alternativen. Es gibt hier bestimmt wen, der das weiß. Auf jeden Fall sollte es eine config geben, in der steht, dass er sich beim boot eine Adresse holt, das kann man auch wenn man einfach nur die Platte mounted nachsehen.
      Wenn es nicht etwas derartig simples ist, wird hier das Debugging schnell wirklich aufwendig und unangenehm, zumal die Software eben wirklich EOL ist, und auf einem sehr alten System läuft. Da würde ich tatsächlich eher zu einer Alternative greifen, mindestens in Software, vielleicht sogar in Hardware.

      Viel Erfolg!
    • getName() wrote:

      Da würde ich tatsächlich eher zu einer Alternative greifen, mindestens in Software, vielleicht sogar in Hardware
      Software wird schwierig, weil das ist halt ein ARM926EJ (fast 20 Jahre alte ARMv5-Familie), der zwar noch von Debians armel-Architektur unterstützt wird, während OMV selbst den Schnitt bei ARMv7 (Debians armhf-Architektur) macht. Heißt: OMV an sich zum Laufen zu bekommen, mag irgendwie funktionieren aber Spaß macht das sicher keinen mehr. Bzgl. vollwertiger Linux Distros abseits Debian gibt es meines Wissens nicht mehr viel für ARMv5.

      Hardware-Aufrüstung? Bei alten NAS-Büchsen, die schon SATA können (dito alte PC) könnte man einen NanoPi M4 mit SATA HAT einbauen aber das lohnt sich m.E. erst mit 4 Bays.

      Wie auch immer... mit der Hardware weiterzubasteln macht ohne serielle Konsole wenig Sinn...
    • tkaiser wrote:

      Wie man Debian 9 auf das Uralt-NAS bekommt, hab ich oben verlinkt (bringt aber wohl nix).
      Ach, sieh mal an. Der Kollege hat ja schon einmal einen Installationsversuch mit OMV vor über einem Jahr unternommen. Und ohne Konsole oder Bildschirmausgabe macht es wohl wirklich wenig Sinn, sich weiter damit zu beschäftigen. Zu viel Aufwand für zu wenig Erfolgschancen. Obwohl ich eigentlich auch einer bin, der Geräte möglichst einer Alternativnutzung zuführen möchte, wenn diese nicht mehr ganz 'up-to-date' sind.
      OMV 3.0.99 (Gray style)
      ASRock Rack C2550D4I C0-stepping - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • cabrio_leo wrote:

      Obwohl ich eigentlich auch einer bin, der Geräte möglichst einer Alternativnutzung zuführen möchte, wenn diese nicht mehr ganz 'up-to-date' sind.
      Geht mir genauso. Aber manchmal hilft halt alles nichts und verkaufen oder zum Recyceln geben ist das einzig Sinnige, was man mit alter Hardware noch machen kann. Bedingt durch ziemliche Heterogenität in der Serverwelt noch vor 15 Jahren hatte ich mal einen ganzen Schrank voll altem Blech, das wir wirklich zu Testzwecken gebraucht haben, um mit MIPS R4000, MIPS R10k, HP PA-RISC, Sun SPARC und UltraSPARC, PowerPC und RS/6000 (IRIX, HP-UX, "altes" SunOS, Solaris, OS X und AIX) testen zu können. Verrückte Welt: damals war ARM noch kein Thema und Intel setzte eigentlich niemand für echte Server™ ein.

      Ein paar der Kisten serverten dann noch mit Linux/Debian vor sich hin aber am Ende gingen die für paar Tacken bei eBay weg bzw. landeten auf dem Wertstoffhof. Selbes Schicksal auch für einen Server, der mir ein wenig ans Herz gewachsen war: einer der ersten PowerMac 9500 mit der damals größtmöglichen HDD-Kapazität von sagenhaften 9GB (Seagate Elite 5,25", volle Bauhöhe). Platte wog glaub ich 5kg und im Manual stand, man solle Sicherheitsschuhe bei der "Montage" tragen :)