Cannot Log in using Web Gui

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Cannot Log in using Web Gui

      For some reason I am locked out of the Web Gui on this machine. I have this scenario.

      I can login to OMV via the command line.
      I can su to root.
      Using omv-firstaid as root does not change anything.

      I cannot bring up the Web Gui using Firefox.
      On one computer I have an older linux running. It runs on another hard drive. When I boot into this system I was able to see the Web Gui and log in. Very confusing.
      However any attempt to Connect to the Web Gui on my main machine using Firefox fails with "Unable to connect" Tried to log in with Chromium browser but found the same result.

      Any ideas. I have looked at the Host-Deny file but nothing appears out of place. Not sure where to go with this.

      The post was edited 3 times, last by bxar ().

      Post by Alanna ().

      This post was deleted by ryecoaaron: spam ().
    • Update: Managed to copy down this error detail after a failed log-in. Hope it may help with resolving this.

      Error #0:
      OMV\Rpc\Exception: Failed to connect to socket: No such file or directory in /usr/share/php/openmediavault/rpc/rpc.inc:140
      Stack trace:
      #0 /var/www/openmediavault/rpc/session.inc(56): OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)
      #1 [internal function]: OMVRpcServiceSession->login(Array, Array)
      #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)
      #4 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)
      #5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
      #6 {main}