FTP 550 error and unable to start transfer

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • FTP 550 error and unable to start transfer

      I have OMV running on an ESXI as a VM. I have got it all configured for sharing the drive near as I can tell but I have been unable to get past this error. I have scoured the internet and many forums for a solution and near as I can tell it is not a permissions thing. My user is part of a group and both the user and group are permitted to RW the drive. When I make changes in OMV and view the directory permissions in SSH they change and seem to be correct. When I try to connect to the shared drive I can connect from a windows machine and view the drive though "Map a Network Drive" but cannot access it. When I use Filezilla, I can connect to the drive but cannot transfer a file and it says "unable to start the transfer". I have been looking through the ACL and the quota and have these set to some values that should allow it so any other pointers would be much appreciated.
    • I am having the same problem:

      - I AM able to open a FTP connection via Filezilla 3.42.1 to an OMV 4.1.22-1 with Linux 4.19.0-0.bpo-4-amd64 kernel.
      - As soon as I try to transfer something, I gat an error 550 Permissions
      - I DID create my user in "Users" in the OMV GUI
      - I am using FTP, not SFTP for I need to integrate a local scanner that is not capable of using SFTP.
      - FTP service in ON (port 21), SFTP is OFF.
      - I created a folder named "ftp" via "shared folders" in the GUI AND added my user to the permitted users.
      - I even tried "usermod -a -G users myusername
      - The ftp folder has these permissions: drwxrwsrwx 2 root users
      - That means that I even tried chmod 0777 on the ftp folder.

      Source Code

      1. Status: Starte Upload von /Users/myself/Desktop/some/folder/file.pdf
      2. Befehl: PASV
      3. Antwort: 227 Entering Passive Mode (192,168,22,65,162,195).
      4. Befehl: STOR file.pdf
      5. Antwort: 550 file.pdf: Keine Berechtigung (No access)
      Any ideas? To me it looks as if no one ever tried to use the OMV FTP server out of the box because that's what I tried.