Questions bevore Upgrade

    • OMV 3.x
    • Upgrade 3.x -> 4.x
    • Questions bevore Upgrade

      My well working omv screms to be upgraded. There are many services running on it and i'am afraid to make any mistakes. So i list all my settings here and hope for any tips.
      OMV version 3.0.99 working with disabled backports Debian GNU/Linux, mit Linux 3.16.0-7-amd64.

      Plugins in use are:
      LVM
      Fail2ban (OMV-Extras)
      FTP
      iSCSI Target
      LetsEncrypt (OMV-Extras)
      MySQL (OMV-Extras)
      NFS
      Nginx (OMV-Extras)
      Plex Media Server (OMV-Extras)
      sensors
      SMB/CIFS
      SSH
      USV
      VirtualBox (OMV-Extras)

      And a Nextcloud installation reachable through the Nginx.

      As i read here there is a simple possibility to upgrade with

      Source Code

      1. omv-release-upgrade
      Before that all Plugins have to be removed ?
      OMV-Extras have to be removed too ?

      Is this right all or have i to do anything else ?

      Tom
    • tomspatz wrote:

      Before that all Plugins have to be removed ?
      No. You need to remove plugins that don't exist on OMV 4.x - iscsitarget and sensors. Not sure what USV is. I would move plex, nextcloud, mysql, and nginx to docker as well.

      tomspatz wrote:

      OMV-Extras have to be removed too ?
      No

      tomspatz wrote:

      Is this right all or have i to do anything else ?
      I would read this - forum.openmediavault.org/index…-basic-update-on-OMV-3-x/
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • tomspatz wrote:

      Where i can find a complete list of plugins from omv 4 ?
      There are two lists. One list is the plugins included with OMV (not sure where an actual list is but iscsi is the only plugin not available on 4.x) and the other is a list of omv-extras plugins (see omv-extras.org).

      tomspatz wrote:

      proftpd ?? never want to install that.
      proftpd is what provides ftp which is in your list.

      tomspatz wrote:

      My "special"Kernel is not a problem ?
      You are using the standard kernel. It is not special. It will be upgraded when moving to OMV 4.x.

      tomspatz wrote:

      iSCSI must be. Any way to make this work on OMV4 ?
      Nope. It doesn't compile on the Debian 9 (OMV 4.x) kernels. You will have to stay on OMV 3.x until OMV 5.x and its iscsi plugin are done.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Users Online 1

      1 Guest