openmediavault cannot be configured

    • OMV 4.x
    • Upgrade 3.x -> 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • openmediavault cannot be configured

      Hallo,

      ich habe mein System von 3.0.99 auf 4.0.12 mit via omv-release-upgrade aktualisiert. Nun kann ich mich nicht mehr in die Web GUI einloggen (Internal Server error), da das Paket openmediavault nicht konfiguriert wurde. Wie kann ich dies beheben?

      Source Code

      1. fail2ban (0.9.6-2) wird eingerichtet ...
      2. Job for fail2ban.service failed because the control process exited with error code.
      3. See "systemctl status fail2ban.service" and "journalctl -xe" for details.
      4. invoke-rc.d: initscript fail2ban, action "start" failed.
      5. ● fail2ban.service - Fail2Ban Service
      6. Loaded: loaded (/lib/systemd/system/fail2ban.service; enabled; vendor preset: enabled)
      7. Active: activating (auto-restart) (Result: exit-code) since Sun 2019-05-12 20:43:43 CEST; 4ms ago
      8. Docs: man:fail2ban(1)
      9. Process: 7879 ExecStart=/usr/bin/fail2ban-client -x start (code=exited, status=255)
      10. Mai 12 20:43:43 kronenb systemd[1]: fail2ban.service: Control process exited, code=exited status=255
      11. Mai 12 20:43:43 kronenb systemd[1]: Failed to start Fail2Ban Service.
      12. Mai 12 20:43:43 kronenb systemd[1]: fail2ban.service: Unit entered failed state.
      13. Mai 12 20:43:43 kronenb systemd[1]: fail2ban.service: Failed with result 'exit-code'.
      14. dpkg: Fehler beim Bearbeiten des Paketes fail2ban (--configure):
      15. Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
      16. openmediavault (4.1.22-1) wird eingerichtet ...
      17. Updating configuration database ...
      18. Running migration conf_4.0.6
      19. Running migration conf_4.0.17
      20. sed: /usr/sbin/omv-mkgraph kann nicht gelesen werden: Datei oder Verzeichnis nicht gefunden
      21. run-parts: /usr/share/openmediavault/mkconf/collectd.d/sensors exited with return code 2
      22. dpkg: Fehler beim Bearbeiten des Paketes openmediavault (--configure):
      23. Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
      24. dpkg: Abhängigkeitsprobleme verhindern Konfiguration von openmediavault-backup:
      25. openmediavault-backup hängt ab von openmediavault (>= 4.1.5); aber:
      26. Paket openmediavault ist noch nicht konfiguriert.
      27. dpkg: Fehler beim Bearbeiten des Paketes openmediavault-backup (--configure):
      28. Abhängigkeitsprobleme - verbleibt unkonfiguriert
      29. dpkg: Abhängigkeitsprobleme verhindern Konfiguration von openmediavault-omvextrasorg:
      30. openmediavault-omvextrasorg hängt ab von openmediavault (>= 4.0.4); aber:
      31. Paket openmediavault ist noch nicht konfiguriert.
      32. dpkg: Fehler beim Bearbeiten des Paketes openmediavault-omvextrasorg (--configure):
      33. Abhängigkeitsprobleme - verbleibt unkonfiguriert
      34. dpkg: Abhängigkeitsprobleme verhindern Konfiguration von openmediavault-nut:
      35. openmediavault-nut hängt ab von openmediavault (>= 4.0.12); aber:
      36. Paket openmediavault ist noch nicht konfiguriert.
      37. dpkg: Fehler beim Bearbeiten des Paketes openmediavault-nut (--configure):
      38. Abhängigkeitsprobleme - verbleibt unkonfiguriert
      39. dpkg: Abhängigkeitsprobleme verhindern Konfiguration von openmediavault-openvpn:
      40. openmediavault-openvpn hängt ab von openmediavault (>= 4.0.12); aber:
      41. Paket openmediavault ist noch nicht konfiguriert.
      42. dpkg: Fehler beim Bearbeiten des Paketes openmediavault-openvpn (--configure):
      43. Abhängigkeitsprobleme - verbleibt unkonfiguriert
      44. dpkg: Abhängigkeitsprobleme verhindern Konfiguration von openmediavault-mysql:
      45. openmediavault-mysql hängt ab von openmediavault (>= 4.0.4); aber:
      46. Paket openmediavault ist noch nicht konfiguriert.
      47. dpkg: Fehler beim Bearbeiten des Paketes openmediavault-mysql (--configure):
      48. Abhängigkeitsprobleme - verbleibt unkonfiguriert
      49. Fehler traten auf beim Bearbeiten von:
      50. fail2ban
      51. openmediavault
      52. openmediavault-backup
      53. openmediavault-omvextrasorg
      54. openmediavault-nut
      55. openmediavault-openvpn
      56. openmediavault-mysql
      57. E: Sub-process /usr/bin/dpkg returned an error code (1)
      Display All


      Vielen Dank!
    • Wenn ich mich richtig erinnere, gab es dieses Problem hier schon öfter. Daher bitte die Suchfunktion nutzen.
      Allgemein wird empfohlen, vor einem Upgrade alle Plugins zu deinstallieren, die es unter OMV4 nicht (mehr) gibt und dann erst das Upgrade ausführen. Falls du ein Image deiner alten Installation hast, könntest du es ja auf diese Art und Weise noch einmal versuchen.
      Mehr kann ich dir dazu leider nicht sagen.
      OMV 3.0.90 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304