OMV 5.0.1 on Qemu fails to install

    • OMV 5.x (development)
    • Update
    • OMV 5.0.1 on Qemu fails to install

      Hi!

      I'm trying to install 5.0.1 (from scratch) on Proxmox (Qemu) but it fails when trying to install GRUB. Any ideas why? Does it require UEFI? Any logs available?
      I got 4.x working just fine with passthrough on the SAS controller, and was thinking of trying out the beta, but can't even finish the install.
    • The OMV5 ISO should support UEFI now, but can not test it if it works.

      You can also use the Debian 10 Netinst ISO and manually install OMV.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • votdev wrote:

      The OMV5 ISO should support UEFI now, but can not test it if it works.
      On VMware with efi boot, the menu screen starts. Start installer fails to find /install/gtk/vmlinuz. live system fails to open /scripts/live and segfaults. live system (failsafe mode) fails on the same /scripts/live missing problem.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • New

      I managed to get it working by skipping bootloader installation, and then booting a Debian Install CD in rescue mode.

      If you run grub-install in chroot you get:

      Shell-Script

      1. grub-install: error /usr/lib/grub/i386-pc/modinfo.sh doesn't exist. Please specify --target or --directory.
      To fix this you need to install grub-pc, it seems it's not installed by default in the beta. So it's using grub with UEFI by default. Which fails on Qemu since it only supports BIOS with default settings.

      As root in the chroot environment you need to run:

      Shell-Script

      1. apt install grub-pc
      2. grub-install
      3. update-grub

      The developers should take a look at this and fix the problem :)
    • New

      ryecoaaron wrote:

      votdev wrote:

      The OMV5 ISO should support UEFI now, but can not test it if it works.
      On VMware with efi boot, the menu screen starts. Start installer fails to find /install/gtk/vmlinuz. live system fails to open /scripts/live and segfaults. live system (failsafe mode) fails on the same /scripts/live missing problem.
      Go to advanced menu and select text mode installer as workaround in the meanwhile.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • New

      votdev wrote:

      Go to advanced menu and select text mode installer as workaround in the meanwhile.
      Ah. hadn't even looked in the Advanced menu. I thought it would just be recovery options. The text mode installer works fine.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!