Bitwarden over Internet

    • OMV 4.x
    • Bitwarden over Internet

      New

      Hi All,
      i have some trouble installing Bitwarden on my OMV 4.x
      i followed TDL Bitwarden guide and worked for me! Thank you for the guide!
      Side note: that costed me a lot of time... if you install it on a ARM-CPU just add the Tag for your architecture. In my case, with a NanoPi M4 was the Tag "aarch64"

      I can't get the Bitwarden to work as i'd like. what i want is when i call mybitwarden.ddns.com that work with SSL.
      URLRESULT
      mybitwarden.ddns.comunable to connect
      mybitwarden.ddns.com:88works without SSL
      mybitwarden.ddns.com:88Source Connection failed
      mybitwarden.ddns.com502 bad gateway with SSL



      My Setup:
      - Running a Letsencrypt Container with ReverseProxy capability
      - NC Container
      - MariaDB Container for NC
      - Gitea non docker (on the docker i could not get it to work)

      NC and Gitea can i reach from the internet over No-IP free DynDNS. So far so good, every thing works fine.

      What i've done to make Bitwarden work:
      On my router i have the port 88 forwarded to 88 for Bitwarden. On the container i map -p 88 : 80
      i tried also to map the network from Bitwarden container to the the Letsencrypt container with the param --network my-net
      i enabeled the bitwarden.subdomain.conf on the Letsencrypt Container:
      /sharedfolders/AppData/Letsencrypt/nginx/proxy-confs/bitwarden.subdomain.conf
      The only change where made is to change the server_name to mybitwarden.*

      the help is really apreciated!
      regards
      fraxor

      The post was edited 2 times, last by fraxor: deleted links from the URL ().

    • Bitwarden over Internet

      New

      I got it to work more or less... but not as i wish i could.
      i followed this guide: github.com/dani-garcia/bitwarden_rs/wiki/Enabling-HTTPS
      and this is the final docker run command:

      Source Code

      1. docker run -d --name bitwarden --restart always \
      2. -e ROCKET_TLS='{certs="/ssl/live/mybitwarden.ddns.com/fullchain.pem",key="/ssl/live/mybitwarden.ddns.com/privkey.pem"}' \
      3. -v /sharedfolders/AppData/Letsencrypt/etc/letsencrypt/:/ssl/ \
      4. -v /sharedfolders/AppData/Bitwarden/:/data/ \
      5. -p 88:80 \
      6. mprasil/bitwarden:aarch64

      finally i can reachBbitwarden with SSL from Internet on Chrome (but not with the Chrome extension), iPhone.
      this is the final URL: mybitwarden.ddns.com:88/#/

      if some one has a hint how to avoid the port param, is very apreciated!
      i could not put the 443 port, because other aps are listening to this port, and if so configured, i got a 502 bad gateway error.
    • New

      fraxor wrote:

      Hi All,
      i have some trouble installing Bitwarden on my OMV 4.x
      i followed TDL Bitwarden guide and worked for me! Thank you for the guide!
      Side note: that costed me a lot of time... if you install it on a ARM-CPU just add the Tag for your architecture. In my case, with a NanoPi M4 was the Tag "aarch64"

      I can't get the Bitwarden to work as i'd like. what i want is when i call mybitwarden.ddns.com that work with SSL.
      URLRESULT
      mybitwarden.ddns.comunable to connect
      mybitwarden.ddns.com:88works without SSL
      mybitwarden.ddns.com:88Source Connection failed
      mybitwarden.ddns.com502 bad gateway with SSL


      My Setup:
      - Running a Letsencrypt Container with ReverseProxy capability
      - NC Container
      - MariaDB Container for NC
      - Gitea non docker (on the docker i could not get it to work)

      NC and Gitea can i reach from the internet over No-IP free DynDNS. So far so good, every thing works fine.

      What i've done to make Bitwarden work:
      On my router i have the port 88 forwarded to 88 for Bitwarden. On the container i map -p 88 : 80
      i tried also to map the network from Bitwarden container to the the Letsencrypt container with the param --network my-net
      i enabeled the bitwarden.subdomain.conf on the Letsencrypt Container:
      /sharedfolders/AppData/Letsencrypt/nginx/proxy-confs/bitwarden.subdomain.conf
      The only change where made is to change the server_name to mybitwarden.*

      the help is really apreciated!
      regards
      fraxor
      Hi,
      can you please post your configuration for bitwarden? Did you used the plugin or you made you via cli?
      I wanted to use it too, but I want to have it only inside my LAN.
      Intel G4400 - Asrock H170M Pro4S - 8GB ram - Corsair VS350W - 2X6TB Seagate Ironwolf - 2x4TB WD RED
      OMV 4.1.17 - Kernel 4.18 backport 3 - omvextrasorg 4.1.2
    • New

      Hi Blabla,
      downloaded the aarch64 docker from mprasil/bitwarden.
      made a shared folder: /sharedfolders/AppData/Letsencrypt/

      then over the CLI i run the command:
      Replace on row 2 the mybitwarden.ddns.com with your hostname
      Replace on row 5 the port with your desired one (in my case is the port 88

      Source Code

      1. docker run -d --name bitwarden --restart always \
      2. -e ROCKET_TLS='{certs="/ssl/live/mybitwarden.ddns.com/fullchain.pem",key="/ssl/live/mybitwarden.ddns.com/privkey.pem"}' \
      3. -v /sharedfolders/AppData/Letsencrypt/etc/letsencrypt/:/ssl/ \
      4. -v /sharedfolders/AppData/Bitwarden/:/data/ \
      5. -p 88:80 \
      6. mprasil/bitwarden:aarch64

      edited the File : /sharedfolders/AppData/Letsencrypt/nginx/proxy-confs/bitwarden.subdomain.conf.sapmle and saved as bitwarden.subdomain.con

      Source Code: bitwarden.subdomain.conf

      1. # make sure that your dns has a cname set for bitwarden and that your bitwarden container is $
      2. server {
      3. listen 443 ssl;
      4. listen [::]:443 ssl;
      5. # replace the <mybitwarden> with your hostname here
      6. server_name <mybitwarden>.*;
      7. include /config/nginx/ssl.conf;
      8. client_max_body_size 128M;
      9. # enable for ldap auth, fill in ldap details in ldap.conf
      10. #include /config/nginx/ldap.conf;
      11. location / {
      12. # enable the next two lines for http auth
      13. #auth_basic "Restricted";
      14. #auth_basic_user_file /config/nginx/.htpasswd;
      15. # enable the next two lines for ldap auth
      16. #auth_request /auth;
      17. #error_page 401 =200 /login;
      18. include /config/nginx/proxy.conf;
      19. resolver 127.0.0.11 valid=30s;
      20. #note that the bitwarden has to match the name of your container!
      21. set $upstream_bitwarden bitwarden;
      22. proxy_pass http://$upstream_bitwarden:80;
      23. }
      24. location /notifications/hub {
      25. include /config/nginx/proxy.conf;
      26. resolver 127.0.0.11 valid=30s;
      27. #note that the bitwarden has to match the name of your container!
      28. set $upstream_bitwarden bitwarden;
      29. proxy_pass http://$upstream_bitwarden:80;
      30. proxy_set_header Upgrade $http_upgrade;
      31. proxy_set_header Connection "Upgrade";
      32. }
      33. location /notifications/hub/negotiate {
      34. include /config/nginx/proxy.conf;
      35. resolver 127.0.0.11 valid=30s;
      36. #note that the bitwarden has to match the name of your container!
      37. set $upstream_bitwarden bitwarden;
      38. proxy_pass http://$upstream_bitwarden:80;
      39. }
      40. }
      Display All
      Restarted Letsencrypt Container and then you can follow the rest of @TDL Guide seting up Bitwarden.

      Hope could helped you out.
      cheerz