SSH und Shell Anmeldung mit admin account funktioniert nicht. In der Web GUI geht es..

    • OMV 3.x
    • Resolved
    • SSH und Shell Anmeldung mit admin account funktioniert nicht. In der Web GUI geht es..

      Guten Tag,

      schon seit einigen Jahren betreibe ich ein OMV NAS. Soweit läuft alles, jetzt rächt sich jedoch meine "Linux null Ahnung".

      Wenn ich mich (ich wollte mal auf die neue Version aktualisieren) über SSH auf dem Mac Terminal, oder über Shellinabox über die Web GUI einloggen möchte, bekomme ich immer ein "permission deined".
      Das Admin Passwort stimmt, ich gebe es ja auch ein um auf die Web GUI zu kommen. Da funktioniert es einwandfrei.
      Was mache ich falsch?
      Liebe Grüße und danke schon mal.
      Images
      • Bildschirmfoto 2019-05-16 um 10.21.52.png

        759.2 kB, 2,094×1,542, viewed 12 times
      • Bildschirmfoto 2019-05-16 um 10.23.29.png

        43.69 kB, 720×262, viewed 8 times
      Version: 3.0.99 (Erasmus)
      Linux 4.9.0-0.bpo.6-amd64
      3,5 GHz Intel Pentium G4560
      8 GB RAM
      Systemdisk: M.2 mit 32 GB
      RAID 5: 4x 3 TB
    • Wow, vielen Dank für die grandios schnelle Antwort! Das bedeutet es gab mal einen weiteren Benutzernamen den ich vergessen habe? Meines Wissens habe ich mich mal erfolgreich eingeloggt, das ist aber Jahre her.

      Deine Anleitung werde ich gleich mal probieren.

      EDIT: Scheint funktioniert zu haben.


      Auch wenn Offtopic: Ein Systembackup habe ich bisher nicht, hast du eine empfehlenswerte Methode oder Anleitung parat? Danke!
      Images
      • Bildschirmfoto 2019-05-16 um 10.44.51.png

        154.56 kB, 1,266×912, viewed 3 times
      Version: 3.0.99 (Erasmus)
      Linux 4.9.0-0.bpo.6-amd64
      3,5 GHz Intel Pentium G4560
      8 GB RAM
      Systemdisk: M.2 mit 32 GB
      RAID 5: 4x 3 TB

      The post was edited 1 time, last by zw3ist3in ().

    • zw3ist3in wrote:

      es gab mal einen weiteren Benutzernamen den ich vergessen habe?
      Ja, root -- da hast Du das Paßwort bei der Installation festgelegt. Aber das macht nix, weil Du über das OMV-Web-UI Zugriff hast und ein solcher sudo-User wie Du ihn jetzt angelegt hast, eh die bessere Idee ist.

      zw3ist3in wrote:

      Ein Systembackup habe ich bisher nicht, hast du eine empfehlenswerte Methode oder Anleitung parat?
      Nö, weil ich OMV nur auf energieeffizienten ARM-Dingern einsetze, wo das von SD-Karte läuft, die ich von Zeit zu Zeit offline klone. Einfach die Forensuche bemühen. Beim Upgrade von OMV3 auf OMV4 kann aber auch relativ wenig schiefgehen (das war nur bei 2 --> 3 schlimm)
    • Users Online 1

      1 Guest