mergerfs 2.26.2 on OMV4 does not work with Plex

    • OMV 4.x
    • Resolved
    • mergerfs 2.26.2 on OMV4 does not work with Plex


      I am running OMV Server (latest OMV4 version) with the most recent version of Plex Media Server (version, non-docker). All my media is on a unisonfilesystem drive. Yesterday I saw that mergerfs has an update to version 2.26.2 (previous version: 2.25.1). After upgrade, Plex is not able to find any files. It always says "File not available". I can play everything with VLC or MPC. Media files on drives outside UnionFS is also works with Plex.

      Now I downgraded mergerfs to version 2.25.1 again and everything works fine.

      Anyone has the same problem or know a solution?
    • I only reboot for kernel updates, but since you mentioned that this may be part of your problem, I did reboot just now. All is well, no problems with Plex and my mergerfs pool.

      I should mention that I do not use the UnionFS plugin, I configure mergerfs by hand directly in /etc/fstab.
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • ah I see. Maybe the unisonFS plugin is the problem. Can you please post your fstab config ? I would like to check if something in my config is wrong.

      my config look is this:

      Source Code

      1. /srv/dev-disk-by-label-xxxx:/srv/dev-disk-by-label-xxxx:/srv/dev-disk-by-label-xxxx:/srv/dev-disk-by-label-xxxx:/srv/dev-disk-by-label-xxxx:/srv/dev-disk-by-label-xxxx /srv/yyyyyyyyyyyyyyyyyyyyyyyyyyy fuse.mergerfs defaults,allow_other,direct_io,use_ino,category.create=mfs,minfreespace=500G 0 0
    • Here is one mergerfs entry from my fstab. There are other as well.

      Source Code

      1. /srv/dev-disk-by-label-d*/multimedia-content-d*/movies /srv/dev-disk-by-label-d1/sftp/outgoing/movies fuse.mergerfs noforget,nonempty,defaults,allow_other,use_ino,func.getattr=newest,category.create=lfs,moveonenospc=true,minfreespace=110G,hard_remove,fsname=mergerfs-movies 0 0
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • Same here, the problem is identified after server reboot.

      I run Plex in docker, so I haven't got plex user under OMV. I added manually a "plexuser" before, who runs plex docker image, he is in users group also.

      I identified mounted media folders isn't appears in plex container since reboot.
    • I do want to make this clear that this issue seems to be limited to Plex. I don't have any issues on my three systems running mergerfs with the plugin.
      omv 5.1.0 usul | 64 bit | 5.3 proxmox kernel | omvextrasorg 5.1.5 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • gadric wrote:

      Can you try to add func.getattr=newe in the mount options of mergerfs partition?
      I made it, and rebooted server after that, but didn't changed.

      I tried to delete and recreate plex container, after that it works again, plex can access files shared from pool.

      What was the problem? (restart plex container didn't helped, need to recreate to make it work)