help needed to install on raspberrypi 3b+

    • help needed to install on raspberrypi 3b+

      I followed the video to install openmediavault on raspi 3b+. When I boot my pi, it gave me bunch of messages as Failed to Install etc. and when finished, it did not gave me any ip address.
      I do not know what to do. I erased and wrote sd card few times but same error.

      Please help.

      Thanks.
    • I believe a common problem is that the future OMV server is not connected, with a network cable, to a network with working DHCP (typically the network router) and internet access.

      If it is not connected to DHCP and the internet the install will most likely fail.

      Connect your rpi to a network with internet access and try to install again.
      OMV 4, 7 x ODROID HC2, 1 x ODROID HC1, 5 x 12TB, 1 x 8TB, 1 x 2TB SSHD, 1 x 500GB SSD, GbE, WiFi mesh
    • Providing a photo of the screen output could give us a hint of what may or may not be the problem.

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • help needed to install on raspberrypi 3b+

      I am trying to install omv on my pi 3b+ but no luck. Installation process runs but it does not give me any ip address as it is suppose to do when installation is complete.

      Any idea what is wrong I am doing? Installation process says, put img on a SD car, insert into pi and turn power on. That is what I did three time with fresh burn of img on SD card, each time.


      Thanks,
    • I have a pi 3b+.
      I followed all the instructions to install the omv but after power up of pi and going through the process, at the end I should get IP address but I do no.
      I see lots of FAILED commands during bootup of pmv.

      Any help?

      I downloaded the ovm from this site for pi.

      Thanks.
    • jhussain wrote:

      Any help?
      Follow the readme at the download location and ensure there is a working Internet connection.

      If you can't allow Internet access then it won't work (the OMV installation needs Internet access to install latest (security) updates, without this it won't work). Once everything is fine you can access your RPi using either raspberrypi or raspberrypi.local

      The post was edited 1 time, last by tkaiser ().

    • jhussain wrote:

      Somewhere I read, do not unzip

      At the download location there's clearly written:

      Source Code

      1. Do not decompress but write the .img.xz image in a single step using Etcher
      2. to SD card: https://etcher.io

      At the very same download location you can also verify checksums by clicking on the info button. At the time of this writing that's

      Source Code

      1. SHA1: 1d3f87ccc90f3b3bac38ebb58fb7366d133026a2
      2. MD5: ff27e253c86abdcd51c533d4841d3ded
      If you're using Windows you need some 3rd party tool to verify your download, on macOS or Linux you can use the md5 or md5sum commands.
    • I am not sure what is going on.

      This time I followed the instructions and used etcher as mentioned but still no IP address shown. After inserting the sd card and power up, pi booted and I can see lots of activity on the screen and then the pi rebooted again. After that it finished and stopped. I still did not see any IP address.

      Thanks.
    • Did you also have the RPi connected to the internet during the installation process?

      Connected with a network cable to a LAN with a DHCP-server and a router with an internet connection? Like a normal home network.

      If you didn't then the installation is expected to fail. As it did.
      OMV 4, 7 x ODROID HC2, 1 x ODROID HC1, 5 x 12TB, 1 x 8TB, 1 x 2TB SSHD, 1 x 500GB SSD, GbE, WiFi mesh
    • Hello Macom!

      Your trick worked. I got the IP address on the terminal. Before that I was using my TV as terminal which may be the issue as you mentioned power issue.

      Now when I put the ip address in the chrome browser of my Win 8.1 computer, it says

      This site can’t be reached
      192.168.1.110 refused to connect.



      What could be the issue now?

      Thanks.
    • Can you ping the address from the command line?
      __________________________________________________

      You might have a firewall issue. If you're using the Windows 8 firewall and you're behind your own router, make sure that the local network is the private network. It should be "connected". If the connected network is "public" you should change it to "home network". This can be done under; Control Panel\All Control Panel Items\Network and Sharing Center. (You could turn the firewall off, for a short test. but don't leave it off.)

      If you're using a 3rd party firewall like ZoneAlarm, you'll need to "trust" the local network (under "Zones") or at least add the IP address of the R-PI (192.168.1.110) and trust it. Other firewalls should be set to medium or low security for the local network.

      **Edit: Connecting OMV's console (port 80) should still work even with firewall settings on high. Connecting to network shares is where a firewall may interfere.**
      ___________________________________________________

      BTW: If being connected to a TV (on the HDMI port) is enough to pull down the power supply, it's too weak. If I remember correctly, 2.5 amps is recommended for the R-PI 3.

      The post was edited 2 times, last by crashtest: edit ().

    • jhussain wrote:

      After inserting the sd card and power up, pi booted and I can see lots of activity on the screen and then the pi rebooted again. After that it finished and stopped.
      Everything is fine then since this is exactly what should happen. If the RPi rebooted then installation finished (it's the same behavior on all the OMV images for ARM but on the RPi it takes more time since a few essential packages are installed at first boot).

      jhussain wrote:

      I still did not see any IP address
      What makes you believe to 'see any IP address' on a monitor connected to your RPi? This will only happen if you login locally as root.

      The recommended behavior is to not connect a display (for the various underpowering issues the RPi is famous for -- usually it's not about amps but resistance and a voltage drop) and to use OMV as headless system. Once installation has finished open a browser and try to access either raspberrypi or raspberrypi.local.
    • I was finally able to get IP address and was able to get into the OMV using the browser.

      Two things I noticed:

      1. With on SD card, it gave me IP address of 192.168.1.xxx, which when I tried in browser gave message of NOT Connected to Serve.

      2. So I burned another SD card and inserted that without any monitor and it gave me IP address of 75.25.xxx.xxx
      This one when I inserted in browser worked and I was able to do the config etc. I can now see my drive listed in the omv page.

      3. But now when I try to map the drive on my PC, I get the following as attached.
      I t asks for Network Credentials and I tried all sort of uid and pwd which I know for my computer, but none worked.

      Any help on this, please.
      Images
      • Network Credentials.JPG

        33.9 kB, 434×364, viewed 22 times
    • jhussain wrote:

      It asks for Network Credentials and I tried all sort of uid and pwd which I know for my computer, but none worked
      Your local user account in Windows is 'admin'. Even if there exists also an account 'admin' in OMV you won't be able to use this account to access shares since the admin account is only for administrating OMV (I really hope your local Windows account called 'admin' has no administration rights, especially if your IP address is now a public one ).

      So what @crashtest suggested won't work. The real problem is that certain guides and tutorials written for newbies miss the most important step when setting up OMV: that's defining at least one normal user account in the OMV UI and using this user then to access shares.

      BTW: while I still have no idea why you're fiddling around with IP addresses (your server is called raspberrypi isn't it?) at least the IP address you're mentioning is strange: 75.25.xxx.xxx is not private IP address.
    • @tkaiser: I entered raspberrypi as you suggested rather than the ip address.
      i can get ino omv.

      I have created a user id using the UI of omv, but still that does not help.

      My question is still why my second sd card gave me a public ip address rather than the dhcp assigned ip from my router?

      Thanks.