Upgrade issue error#0 on 3.x upgrade

    • OMV 3.x
    • Update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Upgrade issue error#0 on 3.x upgrade

      Hi, decided today Id start the upgrade process on my filer to get to 3 and I have experienced an issue logging in after a rather rocky upgrade.

      Heres the stack trace output of the admin page:

      Source Code

      1. Error #0:
      2. exception 'InvalidArgumentException' with message 'The environment variable 'OMV_CONFIGOBJECT_NEW_UUID' does not exist.' in /usr/share/php/openmediavault/environment.inc:47
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(255): OMV\Environment::get('OMV_CONFIGOBJEC...')
      5. #1 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(198): OMV\ControlPanel\ControlPanelAbstract->getBaseBodyContent()
      6. #2 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()
      7. #3 {main}

      i have some plugins still installed, tomorrow Ill back up what I have and toast them


      Source Code

      1. iU openmediavault 3.0.99
      2. ii openmediavault-dnsmasq 2.1
      3. ii. openmediavault-iscsitarget 2.3
      4. ii openmediavault-keyring 0.4
      5. ii openmediavault-lvm2 2.1
      Not sure exactly whats wrong, but am I on the right track thinking an old plugin is calling for the missing object?
    • Zerach wrote:

      a rather rocky upgrade.
      This is why we recommend doing a fresh install over the 2.x->3.x upgrade.

      The openmediavault package itself isn't fully installed. Try apt-get -f install
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Understood, I completely agree.

      This is the home cloud nothing mission critical and I am one to take the journey rather than the destination. Its all about learning for me.

      I’ll take the help if I can get it, but ill invest the time to do this while I try things.

      So looks like I just needed some rest, I thought I resolved my install issue but I didn’t .


      Source Code

      1. You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies: dpkg : Breaks: man-db (< 2.6.3-6~) but 2.6.2-1 is installed E: Unmet dependencies. Try using -f.
      the above was an omv-update command, I have run several dpkg commands and apt-get install -f with similar issues.

      Good (?) news is its not really OMV issue its a man-db issue and the upgrade process stalled because of it.

      Ill update this thread later on today on my progress. Thanks for the support, I am already happy with the kernel improvements going to allow me to do further experimentation with a cloned vm for 4.x upgrade.
    • Apt-get autoremove -f cleared out my install loop, then I ran omv-update I had to remove dnsmasq and a couple other ifxes and the upgrade completed.

      Few more things to fix here and there, but all in all, I am happy

      All of my config/shares etc are there.

      Thanks for your help.