MegerFS/OMV peculiar/slow behaviour

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • MegerFS/OMV peculiar/slow behaviour

      I''ve been reading and digesting the manuals and other threads i found in google but nothing quite covers the issue i have. Or i have missed something, so here i'm.

      I have a pool of 4x2tb WD reds with MergerFS, 250gb WD black for OS, Rig: AMD A10-7850K, asus board Gb onboard, 8gb Ram.
      The server is wired to a Asus AC68U with cat6 and my gaming/workstation has wireless AC68 PCIe card. I get steady 75MB/s with this.
      (I know wired should get me a another 30MB/s but i'm not in a rush when doing bulk transfers)

      I had this issue last year also but it went away after i did a fresh install of OMV4.0 from messed up OMV3 and rebuild the pool from a 8Tb iron wolf back up in December.
      The thing is that it came back a week into running the rig with the new setup. I almost lost my bongers when i saw this again. since that i've been on the issue on and off and thought to give the forums a shot as summer holidays are coming and i can have more time for fixing this, if needed.

      The Behaviour. Protocol Smb/Cifs, Windows 10 to OMV/mergerFs

      When i transfer data to the pool i only get data bursts of about 2gb at max link speed (50-75MBs Wlan, 90-110 wired) then the CPU util drops to idle and transfer rate drops to zero. During transfer CPU in OMV is around 20%.
      The transfer pause can stay like that for minute or so and then the transfer continues at max link speed for another ~2gBs then to zero again. Sometimes i get more than 2gb bursts but at speeds about 30mB/s
      but usually not past 5gb burst. There is no difference which MergerFs settings i use (I've tried direct_ios on/off etc. one disk full first then the next etc, least space, most space...) or how full/empty the drives are and there is no other difference than speed if i use cat6 wire to the AC68U from workstation.

      This is driving me nuts. I don't mind having only 60MBs, i can leave things running when i leave for work but damn i can't handle this kind of weird funkyness from my hardware. :S

      I don't think its HW issue with OMV/merger as PLEX does a fine thing transcoding files on the go without an separate transcode/cache SSD. Also the rebuild of the pool and data recovery from the 8tb drive worked just fine. Also Snapraid and other back ups run fine internally on the rig.

      Anything i can/should do or shall i just suck it up? NFS any better etc...I have saturated my brain on this matter and if nothing else then i could use a different opinion for a change, or if nothing else then some one to say "sorry, nothing you can do!" I need closure! :D

      Thanks.
    • Hi,

      Thanks you for the tips!

      I'll have a read about the samba tune up.

      Had a read test from the pool and i get 95MBs continuous with 10gb file with the wireless to my workstation, and yes only when writing to the pool has this weird up and down bouncing. Only one windows machine actively writing to the pool when i start the transfer, no automatic syncs etc.

      I have the 8TB backup drive shared in the network with smb/cifs and did a write test to it and i get steady 45MBs the whole 10GB file. So some thing with samba, Merger and/or windows is messing the pool writes?

      I do not have another *nix box in the network. I could swap drive to one of my laptops and install something to test if needed.

      I'll report back when i've had a change reading the samba tune threads.
    • Hi,

      Long time waiting to get back on this. Wooo! for summer holidays.

      Few things i've tested and I added a Netgear gigabit switch to which only my work PC and OMV/merger pool are connected. Disabled the Wifi from my WPC.

      The issue remains now with wired connections as well. Tried FTP and it's the same, though i get about 90-95Mbs peak but only for 10-20s then it crashes and FTP reconnects the upload. With smb/cifs i might get the 90-95MBs peaks but it chokes to 20-40MBs for longer than FTP but the transfer will still crash to zero. FTP reconnects faster than SMB/CIFS but crash interval is faster. Load at OMV is about 35% CPU and 15% ram.

      I'm at a loss. I shall backup the whole pool manually, just incase, and rebuild the damn thing for the N'th time. If that wont work i'll reinstall whole OMV for the N'th time. And if this bugger comes back i'll might try out something else, heard a few pointers for unRaid... Might be pain in the ass to swap but i like my things to work 8) I only need Plex or Emby, automatic backup(atm rsync), raid like redundancy for disk fail (snapraid), automatic sync from mobile devices(Currently with Syncthing), and a way to pool the damn drives so i don't have to manually select where the eff i want my files to be stored xD One folder to rule 'em all! with out this you shall not transfer mystery ^^

      I'll give this a few weeks if you can figure out more tips for me to try out.

      Thanks.
    • CeeQuu wrote:

      I'll give this a few weeks if you can figure out more tips for me to try out.
      Another user was having a similar issue, but his appeared to be based around the Realtek network in the server, but his was the transfer actually stopping. What he has done is set the network to manual and forced the realtek to run at 100 rather than 1000.

      This kicked my brain into gear and I remember years ago changing from Full Duplex to Half, I have no idea how you do that on linux, windows it's doable or at least is was.
      Raid is not a backup! Would you go skydiving without a parachute?
    • jollyrogr wrote:

      CeeQuu, just to confirm, you don't have the issue when writing via FTP or SMB to directories outside of a pool?? If that's the case it has to be a mergerfs issue, right?
      Hi,

      Had time to run more tests. I'm pushing through Netgear Prosafe Gigaswitch, GS105 v4. I get steady 65-72MBs to my backupdrive in the same system as the merger pool, whole 30gb test file goes in with out hickups. its a 8tb drive with 1.2tb free so the 70MB cap might be drive space (or my workpc or OMV server hardware is choking.) I get from backup to PC a nice start of 112MBs before the buffers saturate and then a steady 90MBs rest of the way. Target drive on my PC is 1TB "random stuff never defrag" drive.

      So outside the pool things don't bounce. With the gigaswitch i do get about 4gb burst before freeze pause. with the Asus AC68U i get about 2gb so somethings a bit different "direct" to OMV pool.

      I also get this random "not enough space" with large files to some of the folders with both the backup drive and the pool. Pool has 2tb of free and backup 1.2tb so plenty of spave.

      Pool is set mfs - most free space, as i don't care where in the drives data is spread.

      MB on the server side FM2A88x e4 with Qualcomm® Atheros® AR8171, work PC is old (running x58 with a 6c xeon) and has a realtek 8111c chip with latest drivers.

      EDIT:

      Back at it.

      Something kills the lines at OMV side, i think. I had a look at the various logs and i get link kills from all sort of things MiniDLNA reports unexpected link kills at steady pace, FTP bounces all over the place.
      Attached a few pics. I don't know how to verify if its the qualcom or OMV that resets the links when enough stress is put on it with file transfers. Take a look at the FTP transfer log to see the way it bounces the link.
      Images
      • 30gbfrombackuptoPC.PNG

        7.26 kB, 405×187, viewed 39 times
      • 30gbtobackupwired1Gbswitch.PNG

        7.27 kB, 409×193, viewed 29 times
      • ftptranferlog.PNG

        87.28 kB, 1,623×403, viewed 24 times
      • syslogftp.PNG

        109.52 kB, 1,077×595, viewed 35 times

      The post was edited 1 time, last by CeeQuu ().