RAID status after HDD fail/removal while server is turned off

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • RAID status after HDD fail/removal while server is turned off

      I am looking for reliable solution for home/small office NAS decided to try OpenMediaVault

      Created RAID6 with 5 drives
      Tried to simulate drive failure:

      Turned server off and disconnected one random drive,
      but after powering NAS on I could not find any RAID in web UI.
      (disconnecting drive when server is running as expected degrades RAID)

      Then SSH'ed
      and diagnosed using terminal shows that array status is inactive
      solved with mdadm --manage /dev/mdX --run

      Is this intended behavior or bug?

      TL;DR: if HDD fails/is disconnected when system is powered down RAID disappears from web UI, need to run md from terminal for it reaper in UI. Feature?Bug?
    • vjpt wrote:

      I am looking for reliable solution for home/small office NAS decided to try OpenMediaVault

      Created RAID6 with 5 drives
      Tried to simulate drive failure:

      Turned server off and disconnected one random drive,
      but after powering NAS on I could not find any RAID in web UI.
      (disconnecting drive when server is running as expected degrades RAID)

      Then SSH'ed
      and diagnosed using terminal shows that array status is inactive
      solved with mdadm --manage /dev/mdX --run

      Is this intended behavior or bug?

      TL;DR: if HDD fails/is disconnected when system is powered down RAID disappears from web UI, need to run md from terminal for it reaper in UI. Feature?Bug?
      The above does not 'simulate' a drive failure, cat /proc/mdstat will show the raid as inactive have a look here
      Raid is not a backup! Would you go skydiving without a parachute?