Motherboard mit ASMB7 iKVM

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Motherboard mit ASMB7 iKVM

      Hallo zusammen,

      ich habe einige Zeit mit der Installation von omv oder vielmehr der von debian gestritten, bis ich mein Mobo mit ASMB7 iKVM - ein weiteres Asus P9D-I - richtig "zugeritten" hatte.

      Ich hatte, wie meine Signatur besagt, ein solches MoBo schon problemlos für einen OMV in eingesetzt, und war deshalb überrascht, als ein weiteres nicht so einfach mitspielen wollte. Bei näherer Untersuchung stellte sich heraus, das zwar beide Motherboards denselben Stand des BIOS aufwiesen, aber das neue im Boot-Menü zwei "AMI virtual" Drives zeigte, die das schon unter OMV laufende nicht aufwies.
      schon unter einem

      In Bezug auf die Installation von OMV kann das bewirken, dass das OMV-Laufwerk als /dev/sdc - oder bei Installation von einem USB-Stick als /dev/sdd - erkannt wird, und, auch wenn Grub nicht weiter meckert, beim Reboot zunächst ein Debian-Boot (blauer Hintegrund) erscheint, und der OMV-Boot (schwarzer Hintergrund) ins Nirwana geht.

      Daran sind die beiden "AMI virtual" drives Schuld, die das BIOS bereit stellt - zu finden zumindest in der BBS-Auswahl -, und die tatsächlich virtuell, also aktuell nicht zwingend vorhanden sind, was grub und die install-tools unterschiedlich bewerten, aber da letztlich die Meinung von grub zum Zuge kommt, die hier leider die falsche ist, geht der nächste und jeder weitere Reboot gnadenlos baden.

      Es gibt jedoch einen Weg, diese virtuellen Devices loszuwerden. Den BMC selber. Der sich entweder im BIOS irgendwo mit (veränderbarer) fester oder DHCP-Adresse finden lässt, oder im Router/DHCP-Server als unbekannte zugewiesene IP-Adresse. Mit dem Login "admin/admin" kommt man zumindest bei einem ASMB7 ins Web-GUI und kann dort unter Configuration/Services die xx-media-Einstellungen inaktivieren. Mit dem Erfolg, dass beim nächsten Versuch einer OMV-Installation die zugewiesene Festplatte auf /dev/sda bzw., bei Installation von ein USB-Stick, auf /dev/sdb rückt, und damit alle normalen Regeln greifen.

      Offenbar hatte der Vorbesitzer des Motherboards, das ich für meinen Playground OMV verwendetete, die Inaktivierung der AMI Virtual Devices schon selber vorgenommen. Jedenfalls hatte ich mir dem Motherboard keine OMV/Debian-Intallationssprobleme.

      Gruß
      Der Jopa
      Private playground NAS: Asus P9D-I Board + Xeon E3-1220L CPU + 8GB ECC RAM + LSI SAS2108 HBA + upto 7 HDDs + OMV 4 booting from single SLC SSD drive
      Enterprise NAS: Asus CS-B Board + i3-4330T CPU + 4GB RAM + HP SC44Ge Controller + 3x3TB SATA RAID5 + 3x2TB SATA RAID5 + OMV 2.x booting from single SAS drive