Change hostname to uppercase?

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • New

      joq3 wrote:

      Is it possible to change this to be viewed as uppercase by Mac OS for example?
      I get the desired behavior. OMV is called 'NAS' and also displayed as NAS (both AFP and SMB/CIFS):


      Source Code

      1. mac-tk-2018:~ tk$ dns-sd -B _smb._tcp .
      2. Browsing for _smb._tcp
      3. DATE: ---Mon 10 Jun 2019---
      4. 13:52:46.810 ...STARTING...
      5. Timestamp A/R Flags if Domain Service Type Instance Name
      6. 13:52:46.811 Add 2 8 local. _smb._tcp. NAS - SMB/CIFS
      7. ^C
      On which macOS version are you?
    • New

      tkaiser wrote:

      joq3 wrote:

      Is there any other place to set this than in "Network" and Host name?
      The service propagation routines might be patchable. But I provided the output from the dns-sd -B _smb._tcp . for a reason. Why don't you give it a try in Terminal.app to see whether this is a cosmetic issue not related to OMV (Finder showing names only in lowercase for example)?

      Source Code

      1. 18:38:09.027 ...STARTING...
      2. Timestamp A/R Flags if Domain Service Type Instance Name
      3. 18:38:09.027 Add 2 7 local. _smb._tcp. nas - SMB/CIFS
      Images
      • Skärmavbild 2019-06-10 kl. 18.38.42.png

        11.1 kB, 209×241, viewed 7 times
    • New

      tkaiser wrote:

      Well, it's not a macOS issue since the service definition is lowercase. Can't reproduce though (OMV 4.1.22-1).
      Renamed it in OMV to lowercase, saved, and then renamed to uppercase. Now it looks like the attached image.
      No idea why there is another nas there which is not SMB/CIFS.
      Can I remove this somehow?

      Also tried making an Automation to connect to the SMB/CIFS server automatically.
      But it fails because it includes a forward slash I think.

      Source Code

      1. smb://NAS - SMB/CIFS._smb._tcp.local
      However I can connect manually when going trough the Finder.
      But how do I rename it?
      Images
      • Skärmavbild 2019-06-11 kl. 23.03.26.png

        16.08 kB, 253×118, viewed 29 times
    • New

      tkaiser wrote:

      joq3 wrote:

      Also tried making an Automation to connect to the SMB/CIFS server automatically
      It's macOS, so all you need is to save the logon credentials in Keychain.app and then drag the server volume in your login items. System Preferences --> Users&Groups --> Login Items. This is not Windows where everything is complicated as hell...
      Good idea! Just tried it, but I have one annoying issue with this. It will always open my server volume at boot. Even if I check the Hide checkmark. It makes no difference. Is it possible to not have it pop up?