cant delete shared folders

    • cant delete shared folders

      hi

      i have 3 shared folders to an old hdd that is not exist anymore.

      the old hdd is dead and i installed a new one instead.

      but now, i cannot delete or change the shared folders or the old file system (shown as missing).

      what can i do?
      the only thing i can think of, is re-installing the whole system and omv but if there is a better solution - it will be great.


      thanks
    • It's probably nextcloud. While I don't use it, I'm guessing the nextcloud Docker has a "volume and mount point" mapped to the shared folder.

      As long as the shared folder is referenced, it can't be deleted. As long as the shared folder exists, the drive can't be deleted.

      ((And while that may seem odd on the surface, from a practical standpoint it actually makes sense. If it was possible to delete a drive, we'll say it by accident, a lot of configuration work would be lost in a couple clicks.))
      ______________________________________________________

      If you install the "ResetPerm's" plugin, a third tab "Shared Folder In Use" is added to Shared Folders. The entries in this tab will guide you to the services you need to remove or delete, followed by deleting the shared folder itself.

      In the following, to delete either one of the Document shares, their associated smb network share (Samba) would have to be deleted first.

    • ok... so i removed the nc and mariadb from docker and also the images and also in FTP shares i removed the share, in NFS shares i removed the share

      and now its done. no shared folders anymore :)

      thanks

      then i removed the file system that was noted as missing.

      then i created a new shared folder to the new hdd

      then i pulled the images again and everything is working great.

      so thanks a lot :)
    • ok. so now i have a new issue...
      idk if i need to open a new thread...

      after i installed mariadb - the user and database is already exist.
      then i installed the nextcloud but get an error. so i tried several settings... and seems the problem is with forwarding port 80 to 8080.

      this is what i had before, and now when im trying to set this again - i get an error.

      so i forwarded port 80 to 8081 and it went ok.

      but then... when im going to the address, i get this error:
      Internal Server ErrorThe server encountered an internal error and was unable to complete your request.Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.More details can be found in the server log.any ideas?maybe on how to delete all data from previous installation of nc?or how can i fix the issue with port 8080? its say the port is already in use.
    • i deleted the docker installations of mariadb and nc and the shared folder and then deleted the shared folder manually.
      then created the shared folder again and installed mariadb and nc again.
      the mariadb is installed ok.
      the nc is with error again.
      this is the error:

      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; docker run -d --restart=always -v /etc/localtime:/etc/localtime:ro --net=bridge -p 0.0.0.0:8080:80/tcp -p 0.0.0.0:444:443/tcp -e PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin" -e PS1="$(whoami)@$(hostname):$(pwd)\$ " -e HOME="/root" -e TERM="xterm" -e NEXTCLOUD_PATH="/config/www/nextcloud" -v "/sharedfolders/AppData/nextcloud":"/config":rw -v "/sharedfolders/NextCloud":"/data":rw --name="nextcloud" "linuxserver/nextcloud:latest" 2>&1' with exit code '125': 36b7353e043c1e1ebda50d373969149a6f9c842c88bf9b8691b163d9520b08e8 docker: Error response from daemon: driver failed programming external connectivity on endpoint nextcloud (1302b2d3a64ddcacc07dc00fe38803c460022fdc79c95da764e40142babe3abd): Error starting userland proxy: listen tcp 0.0.0.0:8080: bind: address already in use.

      :(

      Post by marik9581 ().

      This post was deleted by the author themselves ().

      Post by marik9581 ().

      This post was deleted by the author themselves ().
    • marik9581 wrote:

      (1302b2d3a64ddcacc07dc00fe38803c460022fdc79c95da764e40142babe3abd): Error starting userland proxy: listen tcp 0.0.0.0:8080: bind: address already in use.
      In the error, I believe the above interesting.
      Dockers are tricky. A single error in configuring a container and that's it.

      Again, do a new thread. While other forum users are familiar with NextClould, I have zero experience with it.