S.M.A.R.T. Read Device Identity failed

    • OMV 4.x
    • Resolved
    • S.M.A.R.T. Read Device Identity failed

      When I enable SMART on my external HDD it gets no information.

      In the information pop-up all tabs give no info, only the ' detailed information tab' states something:
      ------------------------------------------
      smartctl 6.6 2016-05-31 r4324 [x86_64-linux-4.19.0-0.bpo.5-amd64] (local build)
      Copyright (C) 2002-16, Bruce Allen, Christian Franke, smartmontools.org

      Read Device Identity failed: scsi error unsupported field in scsi command


      A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.
      -----------------------------------

      Does someone now what goes wrong?

      I have two other external HDD's attached, which both work fine. I will now explain the differences, but I think my problem can't be in those differences:
      - Those are WD Book (if I remember correctly), the new (not working) one is a Seagate Expansion.
      - I encrypted all three drives. Only thing different is. The WD's I enabled SMART before the encryption. The Seagate I enabled SMART after the encryption.
      - Another difference is that my WD are in raid0, but I only enabled that after enabling SMART, and I want to get rid of the RAID0, because I learned that's not a good idea with external HDD.

      I hope someone can help.
    • Hopsakee wrote:

      SMART on my external HDD
      Welcome to the world of USB3 storage crappiness. The TL;DR variant of your problem is to 'UAS blacklist' your Seagate USB3 disk. Since you're on x86 and not on ARM (where I already took care of this when creating the OMV images for ARM boards) you need to fiddle around with some files: seagate uas blacklist site:openmediavault.org
      No more contributions to this project until 'alternative facts' (AKA ignorance/stupidity) are gone
    • Horay. It worked. I still needed some things to figure out, but I managed thanks to your advice.

      If anyone want to know what I had to do.

      1. read the above post, so you understand what the problem is
      2. don't try this on anything else than a Seagate USB3, because I think other drives might have other problems
      3. ssh as root to you omv device
      4. lsusb => write down the xxxx:yyyy code beloging to your malfunctioning Seagate HDD, and place that on the xxxx:yyyy place in point 4.
      5. echo "options usb-storage quirks=xxxx:yyyy:u" >> /etc/modprobe.d/usb-storage-quirks.conf
      6. update-initramfs -u
      7. reboot
      8. Decide to never ever again try to make a OMV NAS with external HDD's :) (this was not the first problem I ran into)


      Step 4 is based on unix.stackexchange.com/questio…ociated-with-a-usb-device
      Step 5, 6 and 7 if found in the last post of this thread unix.stackexchange.com/questio…n-usb3-hdd-uas-i-o-errors
    • Users Online 1

      1 Guest