haugene/transmission-openvpn port forwarding problem

    • OMV 4.x
    • haugene/transmission-openvpn port forwarding problem

      ello,

      Haugene/transmission-openvpn port forwarding. I am trying to forward the 9091 & 51413 ports. I did the setup in the router but I couldn't set up in the haugene/transmission-openvpn docker.
      I enabled the port forwarding in the config but it doesn't work. I don't see the "CONFIGURING PORT FORWARDING" in my log.

      Thanks,
    • Hello,

      I attached my config and the screenshot of my router settings. My OMV is on 192.168.88.249 address. The port forwarding works on ftp server on port 21.
      I got all "AEAD Decrypt error: bad packet ID (may be a replay):" on all hungarian NORDVPN servers.
      Images
      • grab.PNG

        39.84 kB, 1,768×381, viewed 46 times
      Files
      • cfg.txt

        (18.49 kB, downloaded 25 times, last: )

      The post was edited 4 times, last by Gre@T ().

    • ???

      I tried different MTU sizes. The default 1500 is too big. Maybe this causes the Decrypt Error message? Who knows?
      The 1470 MTU size is good which is mss 1430 (tested under windows).

      I don't know how to forward the 9091 and the 51413 ports. The TDL tutorial doesn't notice the torrent peer port.

      The post was edited 1 time, last by Gre@T ().

    • Gre@T wrote:

      ???

      I tried different MTU sizes. The default 1500 is too big. Maybe this causes the Decrypt Error message? Who knows?
      The 1470 MTU size is good which is mss 1430 (tested under windows).

      I don't know how to forward the 9091 and the 51413 ports. The TDL tutorial doesn't notice the torrent peer port.

      TechnoDadLife wrote:

      I am not familiar with routerOS, but I would think you need to put the source port in, along with the destination port.

      I would look up port forwarding for your router.
      I tested the port with forwarding on my PC (installed qbittorrent) everything is working fine (canyouseeme sees the opened port). But when I am using vpn docker the port seems to be closed. I tried to forward the Cloud commander on port 8000. No luck, I got the same message. The port unreachable for outside. I attached my cofigs and log files.
      Files

      The post was edited 3 times, last by Gre@T ().

    • Hello,

      All my ports bind to ipv6. I disabled the ipv6 in the sysctl file. But I still getting the same ipv6 bindings

      tcp 0 0 0.0.0.0:netbios-ssn 0.0.0.0:* LISTEN 1644/smbd
      tcp 0 0 0.0.0.0:sunrpc 0.0.0.0:* LISTEN 581/rpcbind
      tcp 0 0 0.0.0.0:http 0.0.0.0:* LISTEN 1127/nginx: master
      tcp 0 0 0.0.0.0:ssh 0.0.0.0:* LISTEN 1026/sshd
      tcp 0 0 localhost:2812 0.0.0.0:* LISTEN 1093/monit
      tcp 0 0 0.0.0.0:microsoft-ds 0.0.0.0:* LISTEN 1644/smbd
      tcp 0 0 localhost:nut 0.0.0.0:* LISTEN 1875/upsd
      tcp 0 0 0.0.0.0:4200 0.0.0.0:* LISTEN 1140/shellinaboxd
      tcp6 0 0 [::]:netbios-ssn [::]:* LISTEN 1644/smbd
      tcp6 0 0 [::]:sunrpc [::]:* LISTEN 581/rpcbind
      tcp6 0 0 [::]:ftp [::]:* LISTEN 1196/proftpd: (acce
      tcp6 0 0 [::]:ssh [::]:* LISTEN 1026/sshd
      tcp6 0 0 [::]:microsoft-ds [::]:* LISTEN 1644/smbd
      tcp6 0 0 [::]:8000 [::]:* LISTEN 1452/docker-proxy
      tcp6 0 0 [::]:9091 [::]:* LISTEN 1449/docker-proxy
      tcp6 0 0 [::]:60935 [::]:* LISTEN 1428/docker-proxy
    • As I said, this does not prevent those same ports from working on IPv4.

      Also, your VPN provider must support port forwarding if that is what you are trying to do. Not all VPN providers support this. From

      nordvpn.com/blog/port-forwarding/


      Does port forwarding work with a VPN?


      Port forwarding and triggering could work with a VPN protocol in general, but not with NordVPN.
      --
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • gderf wrote:

      As I said, this does not prevent those same ports from working on IPv4.

      Also, your VPN provider must support port forwarding if that is what you are trying to do. Not all VPN providers support this. From

      nordvpn.com/blog/port-forwarding/


      Does port forwarding work with a VPN?


      Port forwarding and triggering could work with a VPN protocol in general, but not with NordVPN.
      I use port forwarding with Nordvpn.

      Port forwarding is just dependent on your internet provider, how you set up your router and how you set up yoour computer/server/docker.
      Build, Learn, Create.

      How to Videos for OMV

      Post any questions to the forum, so others can benefit from your curiosity. :thumbsup:
      No private support.
    • TechnoDadLife wrote:

      gderf wrote:

      As I said, this does not prevent those same ports from working on IPv4.

      Also, your VPN provider must support port forwarding if that is what you are trying to do. Not all VPN providers support this. From

      nordvpn.com/blog/port-forwarding/


      Does port forwarding work with a VPN?


      Port forwarding and triggering could work with a VPN protocol in general, but not with NordVPN.
      I use port forwarding with Nordvpn.
      Port forwarding is just dependent on your internet provider, how you set up your router and how you set up your computer/server/docker.
      I'm not talking about typical port forwarding in a user's router. I am talking about having a port opened and on the far end of the VPN tunnel on your VPN IP public address forwarded to you.

      For example, say you want to run a web server but you do not want to hand out your real WAN IP address. You want to hand out your public VPN address instead and have the traffic go thru the tunnel to your server. This will require that your VPN provider open a port on their end of the connection and forward it thru the tunnel to you. This is not supported by NordVPN and others.

      Unfortunately, the OP is not being at all clear as to exactly what it is he is trying to do.
      --
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • Hello,

      I am trying to forward a transmission port for example 51413 to the outside world. Without the opened peer port the torrent client is useless no upload and lack of peers.
      The haugene version + Nordvpn service combination doesn't work for me. The peer and the service port (9091) unable to reach from outside.
      I contacted the Nordvpn support they told that we don't support port forwarding (because the illegal uploading on a shared servers.).

      But I have made soem experiment on qbittorrent client on PC.
      I used the Socks5 or Http proxy on the client (qbittorrent) both worked.
      I used to open the port on the router for the PC client.

      And voila the port is open (I checked via canyouseeme.com) I got zero peers for the upload/seed. But In the torrent site stats I got a true seed flag instead of the haugene vpn which gives me a torrent stopped flag because the closed port). PIA supports port forwarding. Unfortunately I have a 3 years subscription on nordvpn :(

      The post was edited 1 time, last by Gre@T ().

    • You shouldn't need any port forwarding set in your router. I use Deluge docker with Socks5 proxy and don't have any ports forwarded. One thing you may notice is that you have a red no incoming connections icon showing but this is not a problem.
      --
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • I said you may see that red icon. Or you may not. You should be absolutely sure that you are really using the proxy though. See these pages for how to properly test this.

      http://ipmagnet.services.cbcdn.com

      torguard.net/checkmytorrentipaddress.php

      I leave those torrents loaded all the time and look at the status from time to time to verify that the proxy is really working and that I am not exposing my real IP address.

      Are you using Deluge 1.3.x or 2.x?
      --
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380

      The post was edited 1 time, last by gderf ().