SMB shares not working on Armbian after update

    • SMB shares not working on Armbian after update

      Hi everyone,

      I have a Helios4 NAS on which I have installed Armbian 5.85. I used the Armbian-Config to install OMV 4.1.23-1 (Arrakis). I used OMV to configure some CMB/CIFS shares which were working properly.

      I connected to my server via SSH, and performed an apt update/upgrade, and I think this broke my SMB shares. According to my Googling, Debian now uses smbd instead of samba. When I try to access my shares at \\192.168.1.x I get a message that says "The specified network name is no longer available." When I run sudo service smbd status, I get the following:

      ● smbd.service - Samba SMB Daemon
      Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
      Active: active (running) since Thu 2019-07-04 12:03:24 UTC; 6min ago
      Docs: man:smbd(8)
      man:samba(7)
      man:smb.conf(5)
      Main PID: 2602 (smbd)
      Status: "smbd: ready to serve connections..."
      Tasks: 3 (limit: 4915)
      CGroup: /system.slice/smbd.service
      ├─2602 /usr/sbin/smbd
      ├─2603 /usr/sbin/smbd
      └─2604 /usr/sbin/smbd

      Jul 04 12:03:24 helios4 systemd[1]: Starting Samba SMB Daemon...
      Jul 04 12:03:24 helios4 systemd[1]: smbd.service: Supervising process 2602 which is not our child. We'll most likely not notice when it exits.
      Jul 04 12:03:24 helios4 smbd[2602]: [2019/07/04 12:03:24.781392, 0] ../lib/util/become_daemon.c:124(daemon_ready)
      Jul 04 12:03:24 helios4 systemd[1]: Started Samba SMB Daemon.
      Jul 04 12:03:24 helios4 smbd[2602]: STATUS=daemon 'smbd' finished starting up and ready to serve connections

      EDIT: when I when sudo service samba status I get

      ● samba.service
      Loaded: masked (/dev/null; bad)
      Active: inactive (dead)


      My /etc/samba/smb.conf file is attached (remove .txt extension)

      Any help appreciated.

      Thanks,
      ~LU
      Files
      • smb.conf.txt

        (1.94 kB, downloaded 42 times, last: )

      The post was edited 1 time, last by LogicalUnit ().

    • geaves wrote:

      LogicalUnit wrote:

      Windows 10 Home 64-bit version 1903
      That should not be the problem then, make sure that Network Discovery is turned on and Function Discovery Resource Publication under services is set to automatic (delayed start) If this had worked previously enabling SMBv1 is not the answer.
      Okay, I have disabled SMBv1 and have ensured that Network discovery is on (currently on a private network) and the Function Discovery Resource Publication service is running.

      How can I change the SMB/CIFS username and password? I might be having problems because I mis-typed the password, and it keeps locking me out.

      EDIT: I've discovered the smbpasswd command and changed my password, but it's still throwing the "The specified network name is no longer available" error.

      The post was edited 1 time, last by LogicalUnit ().

    • LogicalUnit wrote:

      How can I change the SMB/CIFS username and password?
      :?: Just create a user on OMV with the same password as your Windows machine e.g uesername Fred password password, this is case sensitive so if it's Fred then it must be Fred not fred same for the password. The user is added to the user group, you can also add them to the sambashare group.
      That's all you should need to do, have a look at @crashtest guide
      Raid is not a backup! Would you go skydiving without a parachute?
    • @LogicalUnit

      Did creating the user in OMV work? (Identical, cap's and all, to your Windows login username and password)
      (Also) Which logon are you using? The local login or the MS login?

      ________________________

      When this is straightened out, think about cloning your SD-card. With a known working clone in hand, if something like this ever happens again, you'd be able to gracefully back out of a bad update until the cause of a problem is isolated. (A cloning process is in the guide under OS backup.) Along with providing a back-out from misconfiguration, a clone also provides protection from a failed SD-card.

      The post was edited 1 time, last by crashtest: edit ().

    • Okay, what is now consistently happening is that after my SMB shares have been working for a while, I get the dreaded "The specified network name is no longer available" popup, and I can't access my files.

      I then either disable or enable SMB 1.0, and reboot my system, and this at least gets me back to a login prompt when I try to access my shares. I put in the correct username and password, and it gives me access.

      Then it stops working a while later, and I have to repeat these step, either enabling or disabling SMB 1.0 to get the login prompt.

      EDIT: I have added my user (there's only one) to the sambashare group.

      The post was edited 1 time, last by LogicalUnit ().

    • Okay I did a sudo service smbd status and I got the following error


      Aug 02 09:18:54 helios4 smbd[13799]: [2019/08/02 09:18:54.992440, 2] ../source3/param/loadparm.c:2685(lp_do_section)
      Aug 02 09:18:54 helios4 smbd[13799]: Processing section "[media]"
      Aug 02 09:18:54 helios4 smbd[13799]: [2019/08/02 09:18:54.993501, 2] ../source3/param/loadparm.c:2685(lp_do_section)
      Aug 02 09:18:54 helios4 smbd[13799]: Processing section "[main]"
      Aug 02 09:18:54 helios4 smbd[13799]: [2019/08/02 09:18:54.994728, 2] ../source3/auth/auth.c:315(auth_check_ntlm_password)
      Aug 02 09:18:54 helios4 smbd[13799]: check_ntlm_password: Authentication for user [*****@gmail.com] -> [*****@gmail.com] FAILED with error NT_
      Aug 02 09:18:54 helios4 smbd[13799]: [2019/08/02 09:18:54.994917, 2] ../auth/gensec/spnego.c:720(gensec_spnego_server_negTokenTarg)
      Aug 02 09:18:54 helios4 smbd[13799]: SPNEGO login failed: NT_STATUS_NO_SUCH_USER
      Aug 02 09:19:55 helios4 smbd[13799]: [2019/08/02 09:19:55.024345, 2] ../source3/smbd/process.c:2877(deadtime_fn)
      Aug 02 09:19:55 helios4 smbd[13799]: Closing idle connection



      Aug 02 09:19:55 helios4 smbd[13799]: Closing idle connection


      Any idea how to fix? I have edited out my email address.

      The post was edited 1 time, last by LogicalUnit ().

    • LogicalUnit wrote:

      ● samba.service
      Loaded: masked (/dev/null; bad)
      Active: inactive (dead)
      First, looking at the command output of service samba status I got the same message above. My shares are fine with Win7 and Win10.

      Better indicators might be:

      systemctl status smbd (active running) And
      systemctl status nmbd (active running)

      Please reply if both are active and running.

      I don't think this issue is related to a change in smbd. Along the those lines, Armbian is just a tweaked version of Debian. Setting aside the possibility of minor tweaks, I'm guessing that Samba packages are essentially the same between the two. If there was a problem there, more users would be complaining.
      _______________________________________________________________

      geaves wrote:

      What about trying ntlm auth = yes in the extra options
      Did you try this?
      _______________________________________________________________

      On a re-read of the thread, it appears that turning off Local Master Browser fixed the problem for 12 days. (July 12th to the 24th.)
      The only common factor I can come up with might be Win10 updates. A few have been pushed out recently and M$ is known for pushing out security mod's. Since you have Win10 home, I'm guessing it's an OEM version that came with a PC. MS updates and, in some cases, OEM updates can change your security and network settings.

      Take a look at this Win10 Connect How-To and check your general Win10 network settings. (Skip the short cut if you don't need it.)
    • crashtest wrote:

      Did you try this?
      No, mine works but this did come out in another thread.

      crashtest wrote:

      On a re-read of the thread, it appears that turning off Local Master Browser fixed the problem for 12 days.
      That setting conflicts with the wsdd.

      Might be that as mentioned that an MS update has turned something off, i.e. Network Discovery.

      LogicalUnit wrote:

      check_ntlm_password: Authentication for user [*****@gmail.com] -> [*****@gmail.com] FAILED with error NT_

      LogicalUnit wrote:

      SPNEGO login failed: NT_STATUS_NO_SUCH_USER
      Those two errors, there is no need to add an email when creating a user, the second is self explanatory.
      Raid is not a backup! Would you go skydiving without a parachute?

      The post was edited 1 time, last by geaves ().