Nextcloud auf OMV4 / PHP Version wird scheinbar nicht erkannt

    • OMV 4.x
    • Nextcloud auf OMV4 / PHP Version wird scheinbar nicht erkannt

      Hallo
      Ich habe mal versucht Nextcloud auf einem neu installierten OMV4 zu installieren.
      Ich bin nach dieser Anleitung vorgegangen, wogegen ich bei der PHP Version die 5 durch die 7.0 ersetzt habe.
      Bis zur eigentlichen Nextcloud Installation hat auch alles halbwegs funktioniert. Nun gehts aber nicht mehr weiter.
      PHP 7.1 habe ich installiert, aber die Installationsroutine von Nextcloud erkennt die Version scheinbar nicht.
      Siehe Bilder.
      Kann mir jemand weiter helfen?
      Danke schon im Voraus
      Roland
      Images
      • NCinstall.png

        56.12 kB, 389×433, viewed 41 times
      • PHP.png

        23.45 kB, 617×217, viewed 28 times
    • macom wrote:

      Did you follow the video of TDL?

      Others might be able to help if you post some screenshots of your docker settings. Nextcloud and MariaDB.
      Yeah, I followed it. However, I use docker-compose. See config below. I deleted the APP-DATA files and re-downloaded the images and re-created the containers.

      Now I get the following error message during the installation of Nextcloud: 504 Gateway Time-out

      Source Code

      1. nextcloud:
      2. image: linuxserver/nextcloud
      3. container_name: nextcloud
      4. volumes:
      5. - /sharedfolders/AppData/Nextcloud:/config
      6. - /sharedfolders/Nextcloud:/data
      7. - /etc/localtime:/etc/localtime:ro
      8. network_mode: "bridge"
      9. restart: always
      10. environment:
      11. - PUID=1000
      12. - PGID=100
      13. ports:
      14. - 80:80
      15. - 443:443
      16. mariadb:
      17. image: linuxserver/mariadb
      18. container_name: dbnext
      19. volumes:
      20. - /sharedfolders/AppData/Mariadb:/config
      21. - /etc/localtime:/etc/localtime:ro
      22. network_mode: "bridge"
      23. restart: always
      24. environment:
      25. - PUID=1000
      26. - PGID=100
      27. - MYSQL_ROOT_PASSWORD=
      28. - MYSQL_DATABASE=
      29. - MYSQL_USER=
      30. - MYSQL_PASSWORD=
      31. ports:
      32. - 3306:3306
      Display All
    • Is OMV also using port 80?

      If yes, change 80:80 to e.g. 8080:80. Or change the port of OMV in the GUI of OMV.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:

      The post was edited 1 time, last by macom ().

    • macom wrote:

      Is OMV also using port 80?
      [Blocked Image: https://i.imgur.com/3Yd7Xra.png]

      I've already set OMV at port 8080. Suggestions?

      I have added an overview of the ports that are in use. Maybe this will give you a better overview?

      Source Code

      1. root@OMV:~# lsof -i -P
      2. COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
      3. nginx 1037 root 8u IPv4 19302 0t0 TCP *:8080 (LISTEN)
      4. nginx 1038 www-data 8u IPv4 19302 0t0 TCP *:8080 (LISTEN)
      5. nginx 1039 www-data 8u IPv4 19302 0t0 TCP *:8080 (LISTEN)
      6. nginx 1040 www-data 8u IPv4 19302 0t0 TCP *:8080 (LISTEN)
      7. nginx 1040 www-data 16u IPv4 1003541 0t0 TCP 192.168.1.5:8080->192.168.1.18:55559 (EST
      8. nginx 1041 www-data 8u IPv4 19302 0t0 TCP *:8080 (LISTEN)
      9. docker-pr 11899 root 4u IPv6 98343 0t0 TCP *:3306 (LISTEN)
      10. docker-pr 13635 root 4u IPv6 104109 0t0 TCP *:443 (LISTEN)
      11. docker-pr 13649 root 4u IPv6 105493 0t0 TCP *:80 (LISTEN)
      12. EasyAudio 25046 User1 106u IPv4 29610 0t0 TCP 192.168.1.5:33808->82.94.168.18:443 (ESTA
      Display All

      The post was edited 2 times, last by Rickown ().

    • Leider bin ich nicht so vertraut mit der Materie und hab keine Ahnung was es bedeutet "im Docker" zu installieren.
      Ich habe das zwar schon öfter gelesen, aber abgesehen davon, dass ich nicht weiß was das bedeutet und wie das funktioniert, habe ich in dem Zusammenhang auch gelesen, dass es nicht so richtig funktioniert.
    • magnum007 wrote:

      Leider bin ich nicht so vertraut mit der Materie und hab keine Ahnung was es bedeutet "im Docker" zu installieren.
      Ich habe das zwar schon öfter gelesen, aber abgesehen davon, dass ich nicht weiß was das bedeutet und wie das funktioniert, habe ich in dem Zusammenhang auch gelesen, dass es nicht so richtig funktioniert.
      Dem muss ich widersprechen. Ich und auch viele andere Leute hier im Forum haben verschiedenste Dienste problemlos über Docker laufen. Zugegebenermaßen erfordert das Einrichten der Dienste teilweise etwas Einarbeitung, aber man kann eigentlich immer auf die Hilfe der Community hier zählen.
      Wenn du wissen möchtest wie Docker funktioniert gibt eine Menge guter Videos bei YouTube, welche das Ganze erklären.
    • Rickown wrote:

      Now I get the following error message during the installation of Nextcloud: 504 Gateway Time-out
      I assume you removed some information from the compose file for MariaDB (credentials).
      Do you see the nextcloud starting page or do you get the error when you try to reach the page the first time? Have you tried both, http and https?

      What are owner:group and rights for these folders?

      /sharedfolders/AppData/Nextcloud
      /sharedfolders/Nextcloud
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • macom wrote:

      Rickown wrote:

      Now I get the following error message during the installation of Nextcloud: 504 Gateway Time-out
      I assume you removed some information from the compose file for MariaDB (credentials).Do you see the nextcloud starting page or do you get the error when you try to reach the page the first time? Have you tried both, http and https?

      What are owner:group and rights for these folders?

      /sharedfolders/AppData/Nextcloud
      /sharedfolders/Nextcloud

      I have one user named 'User1' and no groups. See the pictures below:

      [Blocked Image: https://i.imgur.com/7FkOZx8.png]

      [Blocked Image: https://i.imgur.com/WVjSmdn.png]

      The user I am now creating for the database is user1, without a capital letter. Can things go wrong at this level?
    • You created the user1 in the GUI of OMV, right? Then he should be member of the users group.

      Can you post the output of:
      ls -l /sharedfolders/AppData/Nextcloud
      ls -l /sharedfolders/Nextcloud
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • macom wrote:

      You created the user1 in the GUI of OMV, right? Then he should be member of the users group.

      Can you post the output of:
      ls -l /sharedfolders/AppData/Nextcloud
      ls -l /sharedfolders/Nextcloud

      I created the user via the GUI or OMV and he is a member of the user group.

      Here are the results:

      Source Code

      1. root@OMV:~# ls -l /sharedfolders/AppData/Nextcloud
      2. total 20
      3. drwxrws---+ 2 User1 users 4096 Jul 15 11:57 keys
      4. drwxrws---+ 4 User1 users 4096 Jul 15 11:57 log
      5. drwxrws---+ 3 User1 users 4096 Jul 15 11:57 nginx
      6. drwxrws---+ 2 User1 users 4096 Jul 15 11:57 php
      7. drwxrws---+ 3 User1 users 4096 Jul 15 11:57 www
      8. root@OMV:~#
      9. root@OMV:~# ls -l /sharedfolders/Nextcloud
      10. total 16
      11. drwxrwx---+ 4 User1 users 4096 Jul 15 12:46 appdata_occmkyf724ch
      12. drwxrwx---+ 2 User1 users 4096 Jul 15 12:45 files_external
      13. -rw-rw---- 1 User1 users 0 Jul 15 12:30 index.html
      14. -rw-r----- 1 User1 users 2140 Jul 15 12:30 nextcloud.log
      15. drwxrwx---+ 3 User1 users 4096 Jul 15 12:30 Rick
      16. root@OMV:~# {
      Display All

      Post by macom ().

      This post was deleted by the author themselves ().
    • Try to change the owner from User1 to user1, as user1 is your new one, right?

      Not sure if that makes a difference as user1 is member of the users group, but try. Make sure to change the owner recursive, so that all files and folders below this folder are also changed.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • Users Online 1

      1 Guest