Using dokuwiki by container, has anybody tried it?

    • OMV 4.x
    • Using dokuwiki by container, has anybody tried it?

      Hi!

      I tried to set up a dokuwiki on my OMV server using docker. I didn't found any guide for that, so I tried it myself.

      I downloaded and used this container: mprasil/dokuwiki

      I configured docker like this:

      Added a name and set restart policy.

      Network mode: bridge
      Port forwarding:
      Host IP: tried with 0.0.0.0 and my OMV server IP address also
      Host port: 4780
      Exposed port: 80/tcp

      Environment variables:
      Tried with add PUID and GUID, and also tired with none added.

      Binded mounts:
      /srv/dev-disk-by-label-data/docker-dokuwiki/data ---> /dokuwiki/data
      /srv/dev-disk-by-label-data/docker-dokuwiki/conf ---> /dokuwiki/conf
      /srv/dev-disk-by-label-data/docker-dokuwiki/lib/plugins ---> /dokuwiki/lib/plugins/
      /srv/dev-disk-by-label-data/docker-dokuwiki/lib/tpl ---> /dokuwiki/lib/tpl/
      /srv/dev-disk-by-label-data/docker-dokuwiki/logs ---> /var/log/

      Other settings are on default.

      I should access dokuwiki on browser by this url, but not works: myomvip:4780/install.php

      Is anyone else used this container, or have an idea what can be the problem?

      Thanks!
    • macom wrote:

      Does the container show up as running in the GUI?
      Have you tried "http://myomvip:4780/install.php"?
      Have you checked the logs of that container?
      What are owner:group and permissions of the bind mounts?
      I deleted and recreated binded folders on the host (OMV) without ACLs, and now it's working.

      Seems it was a permission issue, so thank you very much, dokuwiki install page now appears. :)

      The post was edited 2 times, last by schulcz ().