External HDD not showing existing folders

    • OMV 5.x (development)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • External HDD not showing existing folders

      I have an old external HDD that i am trying to setup in OMV as a simple Samba share. I've connected it, mounted it etc, but when I navigate to it I can't see any of the existing folders or files on it. The HDD shows that it has media on it under storage.

      Is there a way I can simply inherit the existing folder/file structure into my new OMV setup? Or do I need to create new shared folders of the existing folders that are already on the HDD? If so, is there a way of listing all of the folders on the external HDD as I can no longer see them and can't remember all the of the individual names.
    • remf wrote:

      but when I navigate to it I can't see any of the existing folders or files on it.
      How do you navigate?

      When you create a share you should be able to navigate to the target folder.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • remf wrote:

      I navigated through my network to see the shared folder I created.
      For this you probably used SMB/CIFS. First you have to create a shared folder pointing to the folder on the drive and then add this share to SMB/CIFS.

      At least I think it is the same process for OMV5 as it is for OMV4.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • remf wrote:

      I navigated through my network to see the shared folder I created. However it is not showing the folders i previously created on this hard drive when it was connected to another raspberry pi.
      The folders on a hard drive will not be visible on the network until you create shared folders for them within OMV and then also "share them out" via one of the network protocols such as SMB/CIFS.
      --
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • gderf wrote:

      remf wrote:

      I navigated through my network to see the shared folder I created. However it is not showing the folders i previously created on this hard drive when it was connected to another raspberry pi.
      The folders on a hard drive will not be visible on the network until you create shared folders for them within OMV and then also "share them out" via one of the network protocols such as SMB/CIFS.
      yes. This was my understanding. My question is how can I look up the names of the existing folders on the hard drive (there are several) via the command line? I can then add these as shared folders as you explain via SMB.
    • You could use the shell to navigate to the drive and then list the folders using the ls command. I would use ls -al for an abbreviated display.

      Or you could install a program like Midnight Commander that makes this easier (once you learn a bit of it). There are other similar file browser programs available too.
      --
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • gderf wrote:

      You could use the shell to navigate to the drive and then list the folders using the ls command. I would use ls -al for an abbreviated display.

      Or you could install a program like Midnight Commander that makes this easier (once you learn a bit of it). There are other similar file browser programs available too.
      Thank you. But how do I "cd" into the drive or "access" it? What would be the command? I've tried to search but can't find anything. The drive is mounted so I can definitely see it, I'm just not sure how to access it so I can use the 'ls' command as advised.