How to install from USB to USB

    • OMV 4.x
    • How to install from USB to USB

      Hello I am very annoyed after spending over 8 hours downloading, flashing, installing, and wiping my USB drives just to install a simple OS

      Every single time I install it and attempt to boot into the drive I get this error "

      Source Code

      1. Reboot and Select proper Boot device
      2. or Insert Boot Media in selected Boot device and press a key...
      Please help me I don't understand what is wrong.

      EDIT: I remove the install drive but keep the drive that the OS should have been installed to plugged in, this error always shows up

      EDIT: Here's some specs in case you need them

      MSI B360M Pro-VDH mobo
      Intel Pentuim Gold G5400 cpu
      8GB DDR4 3000mhz ram

      The post was edited 2 times, last by 5tanly ().

    • 5tanly wrote:

      I remove the install drive but keep the drive that the OS should have been installed to plugged in, this error always shows up
      That's the norm, when the install media has finished whether it be cd or usb a message appears to tell you to remove the media and reboot.

      Your specific error implies there is no OS on that USB that the system is able to find, the machine booted from the install USB so it appears to have no issue booting from usb.
      Either the install to usb has failed each time or there is a bios setting, I remember reading somewhere that MSI m'boards have a Secure Boot option, disabling this might help, but as it booted from the install usb this may not be the problem.
      Have you tried the usb that omv has been installed on on another machine? this would confirm that the install to the usb was successful and it is capable of booting.
      Raid is not a backup! Would you go skydiving without a parachute?
    • revise BIOS to be sure that USB is the first in the boot selection.

      and please explain what image do you use and what program do you use to write on boot USB

      PD: You can check that USB is bootable trying to boot from it on your desktop PC not only on your NAS ( Because your BIOS order in your NAS can be wrong).
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ; ctop
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • geaves wrote:

      5tanly wrote:

      I remove the install drive but keep the drive that the OS should have been installed to plugged in, this error always shows up
      That's the norm, when the install media has finished whether it be cd or usb a message appears to tell you to remove the media and reboot.
      Your specific error implies there is no OS on that USB that the system is able to find, the machine booted from the install USB so it appears to have no issue booting from usb.
      Either the install to usb has failed each time or there is a bios setting, I remember reading somewhere that MSI m'boards have a Secure Boot option, disabling this might help, but as it booted from the install usb this may not be the problem.
      Have you tried the usb that omv has been installed on on another machine? this would confirm that the install to the usb was successful and it is capable of booting.
      Do I have to remove the install USB when the message shows up or do I hit enter and wait until it reboots itself, then power off and remove the install USB?
    • 5tanly wrote:

      Do I have to remove the install USB
      Remove the usb hit enter and the machine should reboot, if the machine comes up with that message again after/during reboot then the OS (OMV) has not been installed correctly. However if it does boot there will be another error :) but lets get to that point.

      Have you tested the usb that OMV has been installed too on another machine as per @raulfg3 suggestion.
      Raid is not a backup! Would you go skydiving without a parachute?