Enabling SMART crashes OMV

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Enabling SMART crashes OMV

      First time installing OMV I have setup the file system on all of my drives and I have mounted the drives(not sure if I am supposed to do that or not as 2 of them will be in RAID). I have done a quick wipe on all the drives. I am trying to enable SMART however when I go into that section and select devices at the top it spins for a while and says software failure and sends me to the login screen which doesn't let me in. Additionally this happens when I just stay on the SMART general screen and try to enable the switch there to turn on SMART a Hard reboot lets me get back in. Additionally if I just try to go in and setup RAID straight away in Mirroring using my two new WD Reds there are no drives listed under available drives to create RAID with. Thanks for the help.
    • You post is a bit confusing. Sounds like ou created a file system and then wiped the drive

      Process would be
      1. fully update system (wipe function has been improved some versions ago)
      2. wipe drives (quick)
      3. create RAID1 (if you are sure you want RAID1)
      4. create filesystem
      5. enable SMART
      Have you tried like this? Also have a look at the "guide for new users" linked in my signature.

      Please think why you want to have RAID1. Have in mind "RAID is not backup". For me it just adds (in most cases) unnecessary complexity.
      Odroid HC2 - armbian - OMV4.x | Asrock Q1900DC-ITX - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • Still unable to get the drives set here. I created RAID and I mounted that and my one stand alone 500GB drive so all drives are mounted. I still cannot enable SMART I tried from the first smart tab under general. That failed. I also tried from the devices area under SMART section but it just spins for a bit and then tells me communication failure. I think I am close just not quite there yet.
    • So I have installed the disks as described above
      1. fully update system (wipe function has been improved some versions ago)
      2. wipe drives (quick)
      3. create RAID1 (if you are sure you want RAID1)
      4. create filesystem
      5. enable SMART


      Which is a different way from what Technodad shows in his video
      So I have drives, I have RAID1, I have mounted Raid1 and my extra disk. They do both show as referenced NO though not sure what that means.

      My issue is still setting SMART on all of my drives when I go to that section I can flip the general toggle but then it will error when I try to save it forcing me to hard reboot it. Likewise if I select the devices under SMART it goes into a looking state and will eventually fail with a Communication failure error. I will then have to hard boot the machine again to get to a good state. It takes me to a login and locks the session. Any help would be appreciated.