Non Public SMB

    • OMV 4.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Non Public SMB

      Hi all,

      New to OMV, and only really used SMB to set up a network share on windows for my Shield TV to access.

      I have OMV up and running on a Raspberry Pi 4, SMB worked fine, for both the Windows PC and the Shield TV while set up as "Guests Allowed".
      After I change the Public setting to "No" the Shield logs in as a registered user no problems but i keep getting an error on windows
      [Blocked Image: https://i.ibb.co/VpzrXr9/omv-pi4-1.png]

      The windows PC has no problems accesses the SMB share from the shield TV and vice versa

      I know I am probably missing something stupid,

      Thanks in advance for any help
    • Hi thanks for the reply,

      I was previously using a nonsense username and password.

      I'v just Set up a new user with Windows machine User name and password (cap's and all)((user name: TV-PC)), added it to a Group with read/wright privileges, also added privileges to the user specifically.

      I still get the same error.

      ow and yes its windows 10 pro with "SMB 1.0/CIFS File Sharing Support" and "SMB Direct" windows features turned on.
    • DrNickDoom wrote:

      Thanks the 1st step (setting my PC as a Home PC and not part of a business) worked, all shares mounted.
      Awesome. :thumbup:

      DrNickDoom wrote:

      I don't have "homegroup connections" options in the private Advanced Sharing Settings.

      could this be to be a problem ?
      No. The homegroup was one of M$'s bad ideas. They did away with it some time ago, but left it in network options for those who were using it. They may have removed the menu option which means I should take another look at it and update the screen shot.
      ____________________________________________

      DrNickDoom wrote:

      I'v just Set up a new user with Windows machine User name and password (cap's and all)((user name: TV-PC)),
      For future ref:
      For each machine that accesses server shares, setup the same username and password that is used to log into the PC, in OMV, and you should be good to go.
    • crashtest wrote:

      For each machine that accesses server shares, setup the same username and password that is used to log into the PC, in OMV, and you should be good to go.
      I would think this has "only" the advantage that you don't have to enter credentials. Otherwise any user/password should work (and works for me). Well, the user needs to have access to the share ;)
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!: