Unable to open web gui

    • OMV 4.x
    • Unable to open web gui

      Hi, I'm new at this. OMV web gui won't open anymore, it displays error listed below:

      Error #0:
      OMV\Exception: Failed to read file '/var/cache/openmediavault/cache.omv\controlpanel\login_js.json' (size=0). in /usr/share/php/openmediavault/json/file.inc:207
      Stack trace:
      #0 /usr/share/php/openmediavault/json/file.inc(223): OMV\Json\File->getContents()
      #1 /usr/share/php/openmediavault/controlpanel/controlpanelabstract.inc(173): OMV\Json\File->read()
      #2 /var/www/openmediavault/index.php(46): OMV\ControlPanel\ControlPanelAbstract->render()
      #3 {main}

      Can anyone help here?
    • Is this a reinstall? Looks like it could possibly be a cache issue on your browser. You can test if this is the issue by Opening a browser in Privacy/Incognito mode, and trying to log in to the webUI. If it works, then you know it's a cache issue. If it doesn't, then you have other issues.

      If logging in in privacy/incognito mode works... Close that browser

      On a regular browser/tab, Go to the OMV webUI login

      Hold Cntrl and click the Refresh button (this works for Chrome and I'm pretty sure Edge, not sure about Firefox).

      Then try to log in
      Air Conditioners are a lot like PC's... They work great until you open Windows.

    • Tried incognito mode still no working. The problem started when i clonezilla from one disk to another, the only problem was the other disk was a share & smb drive on omv. I rebooted on original disk with other drive detached and this problem occurred, all other functions still work, SSH, dockers, etc (except shared drive of course). Could it be because i unmount that drive first?
    • Madmick65 wrote:

      Sorry, because i didn't unmount that drive first?
      I don't think so..

      Do you have SSH or Console access?

      Try running omv-firstaid and clearing the web cache from there. Then try making sure your apt list is complete... after clearing the cache from omv-firstaid, and you're back at the prompt, omv-aptclean

      and let that run.

      Then refresh your browser as before and see if it works.
      Air Conditioners are a lot like PC's... They work great until you open Windows.

    • Hi,
      That worked, got me into webui, only for me to run into a whole heap of other issues, disk not available, tryied to clear missing disk but just errors, system log full of errors, unable to apply any changes. I think she might be broken. This would be a shame as it has alot of dockers set up and working so well.
      This happens everytime i apply change:

      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; omv-mkconf fstab 2>&1' with exit code '1': Traceback (most recent call last): File "/usr/sbin/omv-mkconf", line 106, in <module> sys.exit(main()) File "/usr/sbin/omv-mkconf", line 101, in main rc = execute_script() File "/usr/sbin/omv-mkconf", line 61, in execute_script os.execv(path, [path] + __args.args) FileNotFoundError: [Errno 2] No such file or directory.

      Also SSH would allow root password anymore?